Bug 146071 - Kernel not updating
Kernel not updating
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 00:20 EST by talaman
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description talaman 2005-01-25 00:20:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
kernel-2.6.9-1.724_FC3 is not updating to kernel-2.6.10-1.741_FC3.
According to the updater I have downloaded and installed the new
kernel. However, when I reboot said new kernel is not in the list of
available kernels. I also checked for the newest vmlinz it too is
/boot/vmlinuz-2.6.10-1.741_FC3.

what gives?



Version-Release number of selected component (if applicable):
kernel-2.6.9-1.724_FC3

How reproducible:
Always

Steps to Reproduce:
1. downloaded kernel
2. kernel seen as being downloaded
3. kernel no worky
    

Additional info:
Comment 1 Dave Jones 2005-01-25 00:32:09 EST
sounds like your /etc/grub.conf never got updated for some reason.
rpm -e the updated kernel, and try again.
Comment 2 talaman 2005-01-26 22:08:02 EST
ok so I don't mess this up, rpm -e <what file>. I was checking for
that grub.conf file. I checked /etc and that is a link: grub.conf ->
../boot/grub/grub.conf. So I checked /boot: 

[root@ehliar boot]# ls
config-2.6.10-1.737_FC3      initrd-2.6.10-1.741_FC3.img 
vmlinuz-2.6.10-1.737_FC3
config-2.6.10-1.741_FC3      System.map-2.6.10-1.737_FC3 
vmlinuz-2.6.10-1.741_FC3
initrd-2.6.10-1.737_FC3.img  System.map-2.6.10-1.741_FC3

no grub file & no grub

did a locate and found:
/etc/sysconfig/grub
/var/spool/up2date/grub-0.95-3.i386.hdr
/sbin/grub-terminfo
/sbin/grub
/sbin/grub-install
/sbin/grubby
/sbin/grub-md5-crypt
/usr/share/vim/vim63/syntax/grub.vim
/usr/share/grub


Any of these likely to be what i need or am I in a pickle?

Comment 3 Sitsofe Wheeler 2005-01-27 18:46:39 EST
What does rpm -q kernel say?
Comment 4 talaman 2005-01-27 23:38:51 EST
[root@ehliar ~]# rpm -q kernel
kernel-2.6.9-1.667
kernel-2.6.9-1.678_FC3
kernel-2.6.9-1.681_FC3
kernel-2.6.9-1.724_FC3
kernel-2.6.10-1.737_FC3
kernel-2.6.10-1.741_FC3
[root@ehliar ~]#
Comment 5 Sitsofe Wheeler 2005-01-28 15:50:52 EST
I take no responsiblity for any consequences of following the actions below. You
do so at your own risk.

As root:
rpm -e kernel-2.6.10-1.741_FC3
yum update

(doing the yum update should prompt you install the new kernel). Keep an eye out
for errors when the kernel is installed.
Comment 6 talaman 2005-01-29 17:18:46 EST
[root@ehliar ~]# yum update
Setting up Update Process
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates-released
repomd.xml                100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 2622/2622
updates-re: ################################################## 615/615
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package authd.i386 0:1.4.3-1 set to be updated
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.10-1.741_FC3.i 100% |=========================| 796 kB    01:02
---> Package kernel.i686 0:2.6.10-1.741_FC3 set to be installed
--> Running transaction check

Dependencies Resolved
Transaction Listing:
  Install: kernel.i686 0:2.6.10-1.741_FC3
  Update: authd.i386 0:1.4.3-1

Other Transactions:
  Obsoleting: pidentd.i386 0:3.0.16-4 with authd.i386 0:1.4.3-1

Is this ok [y/N]: y
Downloading Packages:
authd-1.4.3-1.i386.rpm    100% |=========================|  40 kB    00:05
kernel-2.6.10-1.741_FC3.i 100% |=========================|  16 MB    16:25
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: kernel 100 % done 1/3
Updating: authd 100 % done 2/3
Erasing: pidentd 3/3

Installed: kernel.i686 0:2.6.10-1.741_FC3
Updated: authd.i386 0:1.4.3-1
Obsoleted: pidentd.i386 0:3.0.16-4
Complete!
[root@ehliar ~]#

rebooting now
Comment 7 talaman 2005-01-29 17:31:53 EST
No go on that one either. Guess I will wait for the next version or
two and burn new disks.
Comment 8 Sitsofe Wheeler 2005-01-30 13:06:31 EST
Hmm. What does:
grep 2.6.10 /etc/grub.conf
say? Are you using grub as your bootloader or are you doing something different?
Are you booting with any other operating systems (if so what are they)? What does:
grep boot /etc/fstab
say?
Comment 9 talaman 2005-01-30 14:17:34 EST
$ ls -l /etc | grep grub
lrwxrwxrwx   1 root  root      22 Nov 20  2009 grub.conf ->
../boot/grub/grub.conf

however no /boot/grub/ or /boot/grub/grub.conf exist.

grub as far as I know for the boot loader...I'll reboot to be sure.

Red Hat Fedora Core 3 is the only OS installed on this computer. 


fstab says: $ grep boot /etc/fstab
LABEL=/boot             /boot                   ext3    defaults     
  1 2


will reboot now and post what is has to say.
Comment 10 talaman 2005-01-30 14:55:31 EST
ok, here it is. I am using "GNU Grub Version 0.95". That is according
to that blue screen that comes up if you hit a key within 3 seconds to
choose a different kernel. The kernel-2.6.10-1.741_FC3 or the
kernel-2.6.10-1.724_FC3 (or which ever one was before the latest) do
not show up in said list.

Thanks
Comment 11 Sitsofe Wheeler 2005-01-31 03:05:34 EST
Ok next up what does:
/sbin/fdisk -l
say and can you run
e2label pathtodevice

on those partitions which have a sytem type of linux e.g.
   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         523     4200966    b  W95 FAT32
/dev/hda2             524         525       16065   83  Linux
e2label /dev/hda2

(do NOT put anything after pathtodevice or that partition's label will be
changed! As always you are following these steps at your own risk yadayada...)
Comment 12 talaman 2005-02-02 00:14:48 EST
[root@ehliar ~]# /sbin/fdisk -l

Disk /dev/hda: 30.0 GB, 30020272128 bytes
16 heads, 63 sectors/track, 58168 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         203      102280+  83  Linux
/dev/hda2             204       58168    29214360   8e  Linux LVM

Disk /dev/hdb: 15.3 GB, 15382241280 bytes
255 heads, 63 sectors/track, 1870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1          13      104391   83  Linux
/dev/hdb2              14        1207     9590805   83  Linux
/dev/hdb3            1208        1643     3502170   83  Linux
/dev/hdb4            1644        1870     1823377+   f  W95 Ext'd (LBA)
/dev/hdb5            1644        1708      522081   83  Linux
/dev/hdb6            1709        1838     1044193+  83  Linux
/dev/hdb7            1839        1870      257008+  82  Linux swap


[root@ehliar ~]# e2label /dev/hdb1
/boot
[root@ehliar ~]# e2label /dev/hdb2
/usr
[root@ehliar ~]# e2label /dev/hdb3
/home
[root@ehliar ~]# e2label /dev/hdb4
e2label: Attempt to read block from filesystem resulted in short read
while trying to open /dev/hdb4
Couldn't find valid filesystem superblock.
[root@ehliar ~]# e2label /dev/hdb5
/
[root@ehliar ~]# e2label /dev/hdb6
/var
[root@ehliar ~]# e2label /dev/hdb7
e2label: Bad magic number in super-block while trying to open /dev/hdb7
Couldn't find valid filesystem superblock.
Comment 13 Sitsofe Wheeler 2005-02-02 15:22:38 EST
Hmm! What were the labels on /dev/hda1 and /dev/hda2 (I think I know where this
is going...)
Comment 14 talaman 2005-02-03 20:35:15 EST
[root@ehliar ~]# e2label /dev/hda1
/boot
[root@ehliar ~]# e2label /dev/hda2
/
Comment 15 Sitsofe Wheeler 2005-02-05 19:36:10 EST
Bingo. This sounds like the "two partitions labelled the same does what?!"
problem. talaman, I'm guessing you either added a hard disk from another linux
install OR had an old linux install on one partition and installed FC3 on the
other paritions (or some variation of the above like reinstalling etc.). The
solution is relatively easy assuming you know which parition is the real /boot
and you no longer need the other partition labelled /boot ...

bug #145762 talks a bit about duplicate disk labelling problems. Frankly I have
no idea what should happen and in this case it looks like nothing was mounted
for /boot (talaman, if you do
grep -i boot /var/log/messages
do you turn up any warnings about partitions not being mounted?)
Comment 16 talaman 2005-02-06 00:42:52 EST
Well, I truely wish it were that simple. If, in fact, the
aforementioned was the case....um wouldn't that cause a problem with
EVERY update, and not ONLY the kernel-2.6.10-1.737_FC3 and above. That
is, since nothing has chaged from kernel-2.6.9-1.667 other than the
updates. 

[root@ehliar ~]# rpm -q kernel
kernel-2.6.9-1.667
kernel-2.6.9-1.678_FC3
kernel-2.6.9-1.681_FC3
kernel-2.6.9-1.724_FC3
kernel-2.6.10-1.737_FC3
kernel-2.6.10-1.741_FC3


As to grep -i boot /var/log/messages...I do seem to be getting that at
the moment.
Comment 17 Sitsofe Wheeler 2005-02-06 06:55:57 EST
Now that is plain freaky. Just to rule something out, have you done any hard
disk swaps (either disk) to install FC3 or after installing it?

If not that suggests that something changed (probably in an update) after
kernel-2.6.9-1.724_FC3 was installed that changed the mounting a parition with a
duplicate label behaviour.

What happens if you try and do
mount -L/boot
I'm betting it give some sort of complaint. Perhaps you can try booting back to
the kernel-2.6.9-1.667 and doing the same thing and seeing whether you get a
different result.
Comment 18 Sitsofe Wheeler 2005-02-06 06:57:59 EST
Oh and can you add the output of:
grep mount /var/log/boot*
Comment 19 talaman 2005-02-06 21:45:06 EST
# mount -L/boot
mount: the label /boot occurs on both /dev/hda1 and /dev/hdb1 - not
mounted

/var/log/boot.log.4:Jan 14 19:45:26 ehliar mount: mount: LABEL=/boot
duplicate - not mounted
/var/log/boot.log.4:Jan 14 19:45:26 ehliar mount:
/var/log/boot.log.4:Jan 14 19:45:26 ehliar autofs: automount startup
succeeded
/var/log/boot.log.4:Jan 16 02:24:11 ehliar mount: mount: LABEL=/boot
duplicate - not mounted
/var/log/boot.log.4:Jan 16 02:24:11 ehliar mount:
/var/log/boot.log.4:Jan 16 02:24:11 ehliar autofs: automount startup
succeeded


Comment 20 david le peuple 2005-02-08 19:30:28 EST
Same problem here.

I did a clean install of FC3 on a very old box that had originally
built as RH7 a long time ago then upgraded to RH8 a couple of years
ago. Since the box was old with no large disk support and me being a
newbie then i installed Lilo onto /dev/hdb which was 1.5GB drive not
wishing to risk my OnTrack support for a 13Gb /dev/hda

This weekend I decided to start afresh and did a clean install of FC3
letting the install process 'blow away' everything and chose /dev/hda
to install Grub.

On first boot got

LABEL=/boot duplicate - not mounted error message

and /dev/hda1 & /dev/hdb1 both show as /boot

[root@xxxx boot]# /sbin/e2label /dev/hdb1
/boot
[root@xxxx boot]# /sbin/e2label /dev/hda1
/boot

After doing a yum for updates new kernel 2.6.10-1.760 installed but
uname still points back to 2.6.9-1.667.

/boot has the new vmlinuz etc. but no grub directory.
leading to /etc/grub.conf being a broken link

/dev/hdb1 is particpating in a LVM with /dev/hda2

Hope this sheds some light on the issue

Comment 21 Sitsofe Wheeler 2005-02-09 03:00:43 EST
Comment #20 is slightly different in that we know that you always had a second
/boot partition. The "fix" is simple - change the label of whichever partition
isn't the real boot, mount -L/boot, use rpm to remove the *NEW* kernel and yum
update to reinstall it.

If any one else is hitting this duplicate partition problem they are probably
better off asking for help in the fedora-list mailing list -
http://www.redhat.com/mailman/listinfo/fedora-list . This sort of problem is
more of a support query (how do I configure my system) rather than a typical bug
(when the kernel loads USB2 uchi module it locks up) and bugzilla isn't the best
place to get answers to this sort of thing.

In the case of talaman - I can't understand why this problem should turn up by
itself and I have already mentioned the only things I can think of are adding a
drive at some point after the original install, (re)installing a distro after
the initial install or if the second disk didn't work until you installed
kernel-2.6.9-1.724_FC3 etc. You might find a clue by inspecting date stamps of
the second boot partition. I'm not going to spend any more time investigating it
though.
Comment 22 talaman 2005-02-10 11:19:05 EST
As to comment #20...it's exactly the same thing. Seems for whatever
reason when you download and install the 2.6.10-1.* kernel it wants to
put itself in it's own /boot. To test this I completely and utterly
wiped my system. Reinstalled FC3 and downloaded and installed 255
updates (kernel included) after the updates I started getting /boot
duplicate errors. 

I have, at the moment relabeled /dev/hdb1 to /test and am going to
reboot. 

Will post later on how that turns out.
Comment 23 talaman 2005-02-11 02:57:59 EST
Well, this has been fun. Now I am having issues with my network
adapter starting on boot up. 

Aside from replicating what the update does to install the new kernel,
is there a way to manually install it. Please don't tell me to rpm it,
becuase I'm pretty sure THAT is how the update does it. AND we KNOW
that isn't working. 

Something along the lines of EDIT <filename> decompress <filenameA>
into X directory...etc. etc.
Comment 24 Sitsofe Wheeler 2005-02-11 03:52:04 EST
Comment #23
I really don't recommend trying. Honestly, if you are resorting to that, you are
piling up BIG problems for youself and one breakage is going to lead to another.
Fedora isn't Gentoo : )

I believe all your problems are related to that duplicate partition. You HAVE to
 have /boot mounted (if it was put on a seperate partition) for a properly
working system. Because your /boot was not mounted (due to duplicate partition
labels) when you tried to install the updates, the installing kernel tried to
create a /boot on the partition that / resides on. So now you have two problems
instead of one. This is an unfortunate mess but as mentioned you will most
likely get a better/clearer response to this type of problem on
http://www.redhat.com/mailman/listinfo/fedora-list .

I am not going to recommend any more suggestions because I feel I have already
helped you to create a bigger mess than you had already :(
Comment 25 talaman 2005-02-11 12:25:32 EST
Yeah there have been more problems than not. I think this weekend I'll do
another clean install and when it comes to updating I'll just skip the new
kernel for now until they come out with a newer full OS.
Comment 26 Dave Jones 2005-07-15 13:47:54 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 27 Dave Jones 2005-10-02 20:14:33 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.