Bug 1460723 - Bump SpringFramework to 4.3.9
Bump SpringFramework to 4.3.9
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
4.1.0.3
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Martin Perina
Pavol Brilla
:
Depends On:
Blocks: 1459502 1460725
  Show dependency treegraph
 
Reported: 2017-06-12 09:58 EDT by Martin Perina
Modified: 2017-12-20 06:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:14:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78122 master MERGED core: Bump SpringFramework to 4.3.9 2017-06-19 04:49 EDT

  None (edit)
Description Martin Perina 2017-06-12 09:58:35 EDT
Description of problem:

In order to be able to use latest PostgreSQL JDBC drivers we need to upgrade JDBCTemplate which is part of SpringFramework 4.3.8

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Martin Perina 2017-06-13 03:23:22 EDT
Let's use newest version 4.3.9
Comment 2 Pavol Brilla 2017-11-15 03:29:21 EST
/usr/share/ovirt-engine/modules/common/org/springframework/main/spring-jdbc.jar
...
http://download.eng.bos.redhat.com/brewroot/packages/rhvm-dependencies/4.2.0/1.el7ev/noarch/rhvm-dependencies-4.2.0-1.el7ev.noarch.rpm
...
Comment 3 Sandro Bonazzola 2017-12-20 06:14:23 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.