Bug 1460754 - containers: containers analysis task results - user is system and owner is empty
Summary: containers: containers analysis task results - user is system and owner is empty
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.8.0
Hardware: x86_64
OS: All
Target Milestone: GA
: 5.8.2
Assignee: Mooli Tayer
QA Contact: brahmani
Whiteboard: container:smartstate
Depends On: 1439652
TreeView+ depends on / blocked
Reported: 2017-06-12 15:23 UTC by Satoe Imaishi
Modified: 2017-10-24 00:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1439652
Last Closed: 2017-10-24 00:16:35 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:

Attachments (Terms of Use)
screenshot showing same user (92.71 KB, image/png)
2017-07-03 10:33 UTC, Einat Pacifici
no flags Details

System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:3005 0 normal SHIPPED_LIVE Important: Red Hat CloudForms security, bug fix, and enhancement update 2017-10-24 04:15:49 UTC

Comment 2 CFME Bot 2017-06-12 15:31:16 UTC
New commit detected on ManageIQ/manageiq/fine:

commit b4ad2e25234fd7ef984a682296f9fca6444fe0e1
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu May 25 13:53:09 2017 -0400
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Mon Jun 12 11:26:03 2017 -0400

    Merge pull request #15232 from jrafanie/hack_current_user
    Hack: set current_user since raw_scan_job_create now expects it
    (cherry picked from commit 87061966261086b377c85cf09302938ab7be3029)

 spec/models/job_proxy_dispatcher_spec.rb | 1 +
 spec/models/job_spec.rb                  | 1 +
 2 files changed, 2 insertions(+)

Comment 3 CFME Bot 2017-06-12 15:31:22 UTC
New commit detected on ManageIQ/manageiq/fine:

commit 8bbc28d9fb7086a98ade7ac7011b3f1fb5fa73d0
Author:     Federico Simoncelli <federico.simoncelli@gmail.com>
AuthorDate: Thu May 25 10:25:42 2017 -0400
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Mon Jun 12 11:26:03 2017 -0400

    Merge pull request #24 from moolitayer/set_user
    Set container scanning user
    (cherry picked from commit ad7cdce010b6aeb21eb2d082c0655afd084db511)

 .../manageiq/providers/kubernetes/container_manager_mixin.rb     | 1 +
 .../providers/kubernetes/container_manager/scanning/job_spec.rb  | 9 +++++++--
 .../manageiq/providers/kubernetes/container_manager_spec.rb      | 2 ++
 3 files changed, 10 insertions(+), 2 deletions(-)

Comment 4 Einat Pacifici 2017-07-03 10:11:21 UTC
Verified. User name displayed is now the username of the logged in user e.g. admin

Comment 5 Einat Pacifici 2017-07-03 10:33:52 UTC
Created attachment 1293808 [details]
screenshot showing same user

Moving this back to Dev. 

Steps taken: 
Define user (admin2)
Run scan
View Tasks

Actual result: 

Expected result: 

Did the above steps with user=testuser2 and still: 

Screenshot attached.

Comment 6 Mooli Tayer 2017-07-03 14:05:44 UTC
Thanks Einat!
It took be some time to figure out what is happening.
Check policy prevent checks if a policy wants to cancel the scan and then executes the scan if needed. So we get the Admin user from automate which actually calls for the scan.

I will send the user as argument

Comment 7 Mooli Tayer 2017-07-03 14:09:00 UTC
BTW this isn't the original bug described here but something a little different.
(user != system, but always equals 'admin')

Comment 10 CFME Bot 2017-08-04 17:56:12 UTC
New commit detected on ManageIQ/manageiq/fine:

commit 48e7f137969c479d0b40ffdeac2b1a8a52817a75
Author:     Federico Simoncelli <federico.simoncelli@gmail.com>
AuthorDate: Wed Jul 5 12:10:35 2017 +0200
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Fri Aug 4 13:51:08 2017 -0400

    Merge pull request #54 from moolitayer/ssa_user
    Pass userid before going to automation
    (cherry picked from commit e0e4b5f427aec60e28a15cafd07345f48fcdee25)

 .../providers/kubernetes/container_manager_mixin.rb    | 11 ++++++-----
 .../kubernetes/container_manager/scanning/job_spec.rb  | 18 ++++++++++++++++--
 2 files changed, 22 insertions(+), 7 deletions(-)

Comment 13 brahmani 2017-09-07 07:35:26 UTC
The user problem that was always admin is solved.
But the Owner is still empty.
Mooli as discussed, please provide info on how to ensure owner field has value

Comment 14 Mooli Tayer 2017-09-07 10:29:37 UTC
I'm not sure what owner means or if it has a meaning in this context. Loic any idea?

Comment 15 Loic Avenel 2017-09-07 13:16:03 UTC
Owner is the process owner and Owner message is the what is this process is doing.
Like "external proxy" "collecting data" ..

Using "owner" is confusing here.. for Container Analysis, it can remain empty.

Comment 16 brahmani 2017-09-10 12:17:06 UTC
The user problem that was always admin is solved.
According to Loic it OK that "owner" can remain empty.

Comment 18 errata-xmlrpc 2017-10-24 00:16:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.