Bug 1461072 - [abrt] dnfdragora-gui: __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
[abrt] dnfdragora-gui: __init__.py:250:_handle_dbus_error:dnfdaemon.client.Da...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnfdragora (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Björn 'besser82' Esser
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:1bc74610c94cfae83f285677985...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 09:06 EDT by Mike Simms
Modified: 2018-01-01 17:17 EST (History)
13 users (show)

See Also:
Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-31 16:34:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.07 KB, text/plain)
2017-06-13 09:06 EDT, Mike Simms
no flags Details
File: environ (1.34 KB, text/plain)
2017-06-13 09:06 EDT, Mike Simms
no flags Details

  None (edit)
Description Mike Simms 2017-06-13 09:06:09 EDT
Description of problem:
used 'Open dnfdragora dialog' option from the dnfdragora-updater right-click menu

Version-Release number of selected component:
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.3-202.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
__init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)

Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/pystray/_base.py", line 236, in inner
    callback(self)
  File "/usr/lib/python3.5/site-packages/pystray/_base.py", line 320, in __call__
    return self._action(icon, self)
  File "/usr/lib/python3.5/site-packages/pystray/_base.py", line 414, in wrapper1
    return action(icon)
  File "/usr/lib/python3.5/site-packages/dnfdragora/updater.py", line 109, in __run_dnfdragora
    return self.__run_dialog({})
  File "/usr/lib/python3.5/site-packages/dnfdragora/updater.py", line 104, in __run_dialog
    self.__main_gui = ui.mainGui(args)
  File "/usr/lib/python3.5/site-packages/dnfdragora/ui.py", line 214, in __init__
    rpm_groups = self.backend.GetGroups()
  File "/usr/lib/python3.5/site-packages/dnfdragora/basedragora.py", line 50, in backend
    return self.get_root_backend()
  File "/usr/lib/python3.5/site-packages/dnfdragora/basedragora.py", line 77, in get_root_backend
    self.backend.ExpireCache()
  File "/usr/lib/python3.5/site-packages/dnfdaemon/client/__init__.py", line 401, in ExpireCache
    rc = self._run_dbus_async('ExpireCache', '()')
  File "/usr/lib/python3.5/site-packages/dnfdaemon/client/__init__.py", line 293, in _run_dbus_async
    result = self._get_result(data)
  File "/usr/lib/python3.5/site-packages/dnfdaemon/client/__init__.py", line 277, in _get_result
    self._handle_dbus_error(user_data['error'])
  File "/usr/lib/python3.5/site-packages/dnfdaemon/client/__init__.py", line 250, in _handle_dbus_error
    raise DaemonError(str(err))
dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)

Local variables in innermost frame:
msg: ''
exc: ''
self: <dnfdragora.dnf_backend.DnfRootBackend object at 0x7fbb7fbc7d68>
err: GLib.Error('GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application', 'g-io-error-quark', 36)
Comment 1 Mike Simms 2017-06-13 09:06:15 EDT
Created attachment 1287285 [details]
File: backtrace
Comment 2 Mike Simms 2017-06-13 09:06:17 EDT
Created attachment 1287286 [details]
File: environ
Comment 3 Robert-André Mauchin 2017-08-10 07:33:24 EDT
*** Bug 1476495 has been marked as a duplicate of this bug. ***
Comment 4 Robert-André Mauchin 2017-08-10 07:34:07 EDT
*** Bug 1473324 has been marked as a duplicate of this bug. ***
Comment 5 Robert-André Mauchin 2017-08-10 07:37:45 EDT
*** Bug 1479331 has been marked as a duplicate of this bug. ***
Comment 6 Robert-André Mauchin 2017-08-10 07:40:20 EDT
To solve this problem, launch in a command line:

dnfdragora --exit

It will force the daemon to exit properly.
Comment 7 Hasan Atizaz 2017-11-09 13:30:34 EST
Similar problem has been detected:

dnfdragon shows popup for 18 updates, clicked on it & it crashed.

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.8.6-300.fc25.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000
Comment 8 Jessica Tanenhaus 2017-11-25 21:41:19 EST
Similar problem has been detected:

Ran dnfdragora from system menu. Right-clicked icon in tray and choose 'Check for updates'. Application came back with a crash.

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.9-200.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000
Comment 9 Fedora Update System 2017-12-29 19:23:51 EST
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06
Comment 10 Fedora Update System 2017-12-29 19:25:39 EST
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b
Comment 11 Fedora Update System 2017-12-30 15:00:25 EST
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06
Comment 12 Fedora Update System 2017-12-30 15:46:18 EST
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b
Comment 13 Fedora Update System 2017-12-31 16:34:36 EST
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2018-01-01 17:17:57 EST
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.