Bug 1476495 - [abrt] dnfdragora-gui: _handle_dbus_error(): __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
[abrt] dnfdragora-gui: _handle_dbus_error(): __init__.py:250:_handle_dbus_err...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnfdragora (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Björn 'besser82' Esser
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:1bc74610c94cfae83f285677985...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-29 12:30 EDT by buzz
Modified: 2018-01-01 17:22 EST (History)
10 users (show)

See Also:
Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-31 16:39:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.07 KB, text/plain)
2017-07-29 12:30 EDT, buzz
no flags Details
File: cgroup (289 bytes, text/plain)
2017-07-29 12:30 EDT, buzz
no flags Details
File: cpuinfo (1003 bytes, text/plain)
2017-07-29 12:30 EDT, buzz
no flags Details
File: environ (1.80 KB, text/plain)
2017-07-29 12:30 EDT, buzz
no flags Details
File: mountinfo (3.61 KB, text/plain)
2017-07-29 12:30 EDT, buzz
no flags Details
File: namespaces (102 bytes, text/plain)
2017-07-29 12:30 EDT, buzz
no flags Details
File: open_fds (932 bytes, text/plain)
2017-07-29 12:30 EDT, buzz
no flags Details

  None (edit)
Description buzz 2017-07-29 12:30:05 EDT
Description of problem:
30 seconds after login,  started dnfdragora gui - was all black after a minute it turned white and then disappeared!
Started it again, appears to be ok,  It does seem to crash every now & then. 

Version-Release number of selected component:
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /bin/dnfdragora-updater
kernel:         4.11.11-300.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
__init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 236, in inner
    callback(self)
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 320, in __call__
    return self._action(icon, self)
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 414, in wrapper1
    return action(icon)
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 109, in __run_dnfdragora
    return self.__run_dialog({})
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 104, in __run_dialog
    self.__main_gui = ui.mainGui(args)
  File "/usr/lib/python3.6/site-packages/dnfdragora/ui.py", line 214, in __init__
    rpm_groups = self.backend.GetGroups()
  File "/usr/lib/python3.6/site-packages/dnfdragora/basedragora.py", line 50, in backend
    return self.get_root_backend()
  File "/usr/lib/python3.6/site-packages/dnfdragora/basedragora.py", line 77, in get_root_backend
    self.backend.ExpireCache()
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 401, in ExpireCache
    rc = self._run_dbus_async('ExpireCache', '()')
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 293, in _run_dbus_async
    result = self._get_result(data)
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 277, in _get_result
    self._handle_dbus_error(user_data['error'])
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 250, in _handle_dbus_error
    raise DaemonError(str(err))
dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)

Local variables in innermost frame:
msg: ''
exc: ''
err: GLib.Error('GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application', 'g-io-error-quark', 36)
self: <dnfdragora.dnf_backend.DnfRootBackend object at 0x7fdde8fecf98>

Potential duplicate: bug 1461072
Comment 1 buzz 2017-07-29 12:30:11 EDT
Created attachment 1306323 [details]
File: backtrace
Comment 2 buzz 2017-07-29 12:30:12 EDT
Created attachment 1306324 [details]
File: cgroup
Comment 3 buzz 2017-07-29 12:30:13 EDT
Created attachment 1306325 [details]
File: cpuinfo
Comment 4 buzz 2017-07-29 12:30:14 EDT
Created attachment 1306326 [details]
File: environ
Comment 5 buzz 2017-07-29 12:30:15 EDT
Created attachment 1306327 [details]
File: mountinfo
Comment 6 buzz 2017-07-29 12:30:16 EDT
Created attachment 1306328 [details]
File: namespaces
Comment 7 buzz 2017-07-29 12:30:17 EDT
Created attachment 1306329 [details]
File: open_fds
Comment 8 Simon 2017-08-03 05:04:36 EDT
Similar problem has been detected:

update had finished, I tried to close the window and got this error

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /bin/dnfdragora-updater
kernel:         4.11.11-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.baseurl.DnfSystem.LockedError: dnf is locked by another application (36)
runlevel:       N 5
type:           Python3
uid:            1000
Comment 9 Robert-André Mauchin 2017-08-10 07:33:24 EDT
Solution:
# yumex-dnf --exit

*** This bug has been marked as a duplicate of bug 1461072 ***
Comment 10 Robert-André Mauchin 2017-08-10 07:38:57 EDT
Sorry it's:
dnfdragora --exit
Comment 11 Miroslav Avramov 2017-08-12 16:24:13 EDT
*** Bug 1480908 has been marked as a duplicate of this bug. ***
Comment 12 al morris 2017-09-04 23:28:41 EDT
*** Bug 1488287 has been marked as a duplicate of this bug. ***
Comment 13 bob 2017-10-28 12:16:45 EDT
*** Bug 1507241 has been marked as a duplicate of this bug. ***
Comment 14 David Poulsen 2017-10-30 03:28:04 EDT
*** Bug 1507405 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2017-12-29 19:41:07 EST
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06
Comment 16 Fedora Update System 2017-12-29 19:43:08 EST
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b
Comment 17 Fedora Update System 2017-12-30 15:05:09 EST
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06
Comment 18 Fedora Update System 2017-12-30 15:50:50 EST
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b
Comment 19 Fedora Update System 2017-12-31 16:39:36 EST
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2018-01-01 17:22:38 EST
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.