Bug 1461083 - Use ovirt-host package for pulling in needed dependencies
Use ovirt-host package for pulling in needed dependencies
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
2.2.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.2.0
: 2.2.0
Assigned To: Sandro Bonazzola
Liran Rotenberg
: FutureFeature
Depends On: 1460609
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 09:24 EDT by Sandro Bonazzola
Modified: 2018-02-22 04:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-22 04:58:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑4.2?
mavital: testing_plan_complete-
rule-engine: planning_ack?
sbonazzo: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78302 master MERGED packaging: setup: require ovirt-host 2017-06-20 02:47 EDT

  None (edit)
Description Sandro Bonazzola 2017-06-13 09:24:59 EDT
Consume ovirt-host instead of specify single dependencies for running oVirt hosts.
Comment 1 Liran Rotenberg 2018-02-13 07:13:27 EST
Verified:
ovirt-hosted-engine-setup-2.2.9-1.el7ev.noarch

Steps of verification:
1. Check ovirt-hosted-engine-setup dependencies


Result:

# repoquery --requires ovirt-hosted-engine-setup
/bin/sh
/usr/bin/python
ansible >= 2.4
bind-utils
genisoimage
glusterfs-cli >= 3.8.0
iptables
iptables-services
libselinux-python
libvirt-client
libvirt-daemon-config-network
lsof
m2crypto
openssh-server
openssl
otopi >= 1.7.3
ovirt-engine-sdk-python >= 3.6.9.1
ovirt-host >= 4.2.0
ovirt-host-deploy >= 1.7.0
ovirt-hosted-engine-ha >= 2.2.3
ovirt-setup-lib >= 1.1.3
pyliblzma
python
python(abi) = 2.7
python-ethtool >= 0.6-3
python-libguestfs
python-netaddr
python-ovirt-engine-sdk4
python-six
qemu-img-rhev
sanlock >= 2.8
sanlock-python >= 2.8
sudo
vdsm-python >= 4.20.8
virt-install
Comment 2 Sandro Bonazzola 2018-02-22 04:58:24 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.