Bug 1460609 - Introduce ovirt-host package
Introduce ovirt-host package
Status: CLOSED CURRENTRELEASE
Product: ovirt-distribution
Classification: oVirt
Component: ovirt-host (Show other bugs)
4.1.2
Unspecified Unspecified
urgent Severity high (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Sandro Bonazzola
Pavol Brilla
: FutureFeature
Depends On: 1495854
Blocks: 1380498 1408942 1429855 1460708 1461081 1461083 1491203 1503442
  Show dependency treegraph
 
Reported: 2017-06-12 04:05 EDT by Shirly Radco
Modified: 2018-01-18 11:15 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
A new package, ovirt-host, has been introduced, consolidating host package requirements into a single meta package.
Story Points: ---
Clone Of:
: 1491203 (view as bug list)
Environment:
Last Closed: 2017-12-20 06:29:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
pstehlik: testing_plan_complete-
ylavi: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78075 master ABANDONED packaging: spec: introduce ovirt-release-host-requirements 2017-06-12 08:20 EDT

  None (edit)
Description Shirly Radco 2017-06-12 04:05:20 EDT
Description of problem:
Consolidate ovirt host requirements to a single meta package, to deal with the current package installation and upgrade issues.

Infra and integration need to agree on one place where the list of required packages are installed/updated per arch per version.
Comment 1 Martin Perina 2017-06-12 04:19:36 EDT
Since 3.6 it's no longer true that all package dependencies on the host are handled by RPM dependency of VDSM. At the moment some we have several place where packages for the host required by oVirt are defined:

1. vdsm package dependencies (defined per VDSM version)
2. ovirt-host-deploy package list (defined per ovirt-host-deploy version)
3. Host upgrade manager package list (defined per cluster version)

This status makes nearly impossible to achieve the same package status for different upgrade methods:

1. Manual 'yum update' on the host
2. Executing host 'Upgrade' from webadmin
3. Executing host 'Reinstall' from webadmin

So we need to move host package dependencies on the host by create ovirt-host-X.Y.Z package which will define dependencies of the host for specific oVirt X.Y.Z
Comment 2 Sandro Bonazzola 2017-06-12 04:41:48 EDT
What's the question?
Comment 3 Yaniv Lavi 2017-06-12 04:43:07 EDT
The goal should be:
- In host deploy only this package is required to get all deps installed per arch, per version.
- Engine only updates this package to get the oVirt deps updated 
- The node only requires this package to build.

The host side holds the list of packages to update so that (to remove the need of engine being aware of the host version\arch):
- Node host lists only the image rpm name to update.
- RHEL-H only lists this meta-data package to update.
Comment 4 Sandro Bonazzola 2017-06-12 08:39:11 EDT
(In reply to Yaniv Lavi from comment #3)
> The goal should be:
> - In host deploy only this package is required to get all deps installed per
> arch, per version.

ack

> - Engine only updates this package to get the oVirt deps updated 

ack

> - The node only requires this package to build.

No, node and non-node hosts differ at least in imgbased and nodectl presence.
We need to decide if we want to enforce all the other packages installed on node to be also installed on plain hosts.

> The host side holds the list of packages to update so that (to remove the
> need of engine being aware of the host version\arch):
> - Node host lists only the image rpm name to update.
> - RHEL-H only lists this meta-data package to update.
Comment 5 Pavol Brilla 2017-12-15 05:22:53 EST
Package is installable, 4.2 host to 4.2 engine SUCCESS
Comment 6 Sandro Bonazzola 2017-12-20 06:29:43 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.