Bug 1461346 - Old statefulset resources'event displayed for new statefulset of same name
Old statefulset resources'event displayed for new statefulset of same name
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 05:22 EDT by shahan
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When deleting a resource and creating a new resource with the same name, it was possible to see events for the old, deleted resource in the web console on the new resource's page. This has been fixed. Now only events for the new resource will display in the web console even when the name is reused.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:28:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The new statefulset events (71.68 KB, image/png)
2017-06-14 05:22 EDT, shahan
no flags Details

  None (edit)
Description shahan 2017-06-14 05:22:00 EDT
Created attachment 1287573 [details]
The new statefulset events

Description of problem:
In the same namespace, if you delete a statefulset and create a new one with the same name, the old statefulset's events will be displayed as part of the new statefulset's events.
This is similar to the old-new chart issue in https://bugzilla.redhat.com/show_bug.cgi?id=1386838

Version-Release number of selected component (if applicable):
OpenShift Master:v3.6.106 (online version 3.5.0.20)
Kubernetes Master:v1.6.1+5115d708d7 

How reproducible:
Always

Steps to Reproduce:
1.Create statefulset resources
# oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/statefulset/statefulset-hello.yaml
2.Enter 'Application'->'Stateful Set'-> 'Events' page, check event messages
3. Delete the Statefulset, and create new one with same yaml file
4. Do step2.

Actual results:
4. You see the old statefulset events were displayed as part of the new statefulset's events(see attachment)

Expected results:
4. Only display the new statefulset events.


Additional info:
See same issue on free-int cluster.
Comment 2 openshift-github-bot 2017-06-15 20:20:21 EDT
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/bed0feeac9e270f737af8f454b7de72854281d33
Bug 1461346 - Filter events by UID

Use the API object UID rather than kind and name to filter events. This
prevents events for showing for a previous object with the same name.
Comment 4 shahan 2017-06-28 23:27:01 EDT
Checked this issue, it was fixed.  The new statefulset's events would not display the old.
Comment 6 errata-xmlrpc 2017-08-10 01:28:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.