Bug 1461426 - Schema provided by cinnamon-settings-daemon conflicts with one from gnome-settings-daemon
Schema provided by cinnamon-settings-daemon conflicts with one from gnome-set...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon-settings-daemon (Show other bugs)
25
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
: Reopened
: 1462470 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 08:30 EDT by David Jansen
Modified: 2017-06-23 16:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: cinnamon-settings-daemon-3.4.1-2.fc26 cinnamon-settings-daemon-3.4.2-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-23 16:53:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2017-06-14 08:30:23 EDT
Description of problem:

When both cinnamon-settings-daemon and gnome-settings-daemon are installed, this errors pops up:
/usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.sharing.gschema.xml:17:1  Error on line 17 char 1: <schema id='org.gnome.settings-daemon.plugins.sharing.service'> already specified.  This entire file has been ignored.

This happens every time glib-compile-schemas is executed, often from the post-install scripts from rpm packages.

Version-Release number of selected component (if applicable):
cinnamon-settings-daemon-3.4.1-1.fc25.x86_64
gnome-settings-daemon-3.22.2-1.fc25.x86_64

How reproducible:


Steps to Reproduce:
1. dnf install cinnamon-settings-daemon gnome-settings-daemon
2. glib-compile-schemas /usr/share/glib-2.0/schemas (or install packages that run that command from their scripts)

Actual results:
/usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.sharing.gschema.xml:17:1  Error on line 17 char 1: <schema id='org.gnome.settings-daemon.plugins.sharing.service'> already specified.  This entire file has been ignored.

And indeed, the file is being ignored; other references to items defined in that file will result in more error messages, e.g.:
warning: undefined reference to <schema id='org.gnome.settings-daemon.plugins.sharing'/>


Expected results:
No errors and warnings, and functioning definitions

Additional info:

The warning goes away when the reference to gnome in /usr/share/glib-2.0/schemas/org.cinnamon.settings-daemon.plugins.sharing.gschema.xml is changed to cinnamon:
sed -i 's/gnome/cinnamon/' /usr/share/glib-2.0/schemas/org.cinnamon.settings-daemon.plugins.sharing.gschema.xml
glib-compile-schemas /usr/share/glib-2.0/schemas

But I'm not an expert, and I don't know for sure that that is a proper fix for this issue.
Comment 1 Fedora Update System 2017-06-14 11:43:50 EDT
cinnamon-settings-daemon-3.4.1-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b6f66de860
Comment 2 Fedora Update System 2017-06-14 11:43:58 EDT
cinnamon-settings-daemon-3.4.1-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3855ccffec
Comment 3 Fedora Update System 2017-06-15 06:58:31 EDT
cinnamon-settings-daemon-3.4.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3855ccffec
Comment 4 Fedora Update System 2017-06-15 10:00:15 EDT
cinnamon-settings-daemon-3.4.1-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b6f66de860
Comment 5 Fedora Update System 2017-06-16 09:20:55 EDT
cinnamon-settings-daemon-3.4.1-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 leigh scott 2017-06-18 01:59:35 EDT
*** Bug 1462470 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2017-06-21 11:55:21 EDT
cinnamon-3.4.2-1.fc25 cinnamon-settings-daemon-3.4.2-1.fc25 nemo-3.4.3-1.fc25 cinnamon-screensaver-3.4.1-1.fc25 cinnamon-session-3.4.1-1.fc25 cinnamon-desktop-3.4.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4349ca6a71
Comment 8 Fedora Update System 2017-06-22 23:28:26 EDT
cinnamon-3.4.2-1.fc25, cinnamon-desktop-3.4.2-1.fc25, cinnamon-screensaver-3.4.1-1.fc25, cinnamon-session-3.4.1-1.fc25, cinnamon-settings-daemon-3.4.2-1.fc25, nemo-3.4.3-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4349ca6a71
Comment 9 Fedora Update System 2017-06-23 16:53:53 EDT
cinnamon-3.4.2-1.fc25, cinnamon-desktop-3.4.2-1.fc25, cinnamon-screensaver-3.4.1-1.fc25, cinnamon-session-3.4.1-1.fc25, cinnamon-settings-daemon-3.4.2-1.fc25, nemo-3.4.3-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.