This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1462470 - Installation of Cinnamon breaks file sharing in GNOME
Installation of Cinnamon breaks file sharing in GNOME
Status: CLOSED DUPLICATE of bug 1461426
Product: Fedora
Classification: Fedora
Component: cinnamon-settings-daemon (Show other bugs)
25
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-17 19:01 EDT by Jacek Krüger
Modified: 2017-06-18 01:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 01:59:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Krüger 2017-06-17 19:01:51 EDT
GSettings schema compilation fails:

$ LC_ALL=C glib-compile-schemas /usr/share/glib-2.0/schemas/
/usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.sharing.gschema.xml:17:1  Error on line 17 char 1: <schema id='org.gnome.settings-daemon.plugins.sharing.service'> already specified.  This entire file has been ignored.

That is due to /usr/share/glib-2.0/schemas/org.cinnamon.settings-daemon.plugins.sharing.gschema.xml file from cinnamon-settings-daemon-3.4.1-1.fc25.x86_64 package that has duplicated schema with id="org.gnome.settings-daemon.plugins.sharing.service".

This in turn causes gnome-settings-daemon to skip 'sharing plugin' when loading modules:
> Jun 17 23:09:15 yoga-kruger gnome-settings-[3914]: Ignoring unknown module 'org.gnome.settings-daemon.plugins.sharing'

And then you cannot enable file sharing via GUI from gnome-control-center (the toggle remains off):
> Jun 18 00:57:04 yoga-kruger gnome-control-c[8475]: Failed to enable service rygel: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SettingsDaemon.Sharing was not provided by any .service files
> Jun 18 00:57:04 yoga-kruger gnome-control-c[8475]: couldn't list networks: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SettingsDaemon.Sharing was not provided by any .service files
Comment 1 leigh scott 2017-06-18 01:59:35 EDT

*** This bug has been marked as a duplicate of bug 1461426 ***

Note You need to log in before you can comment on or make changes to this bug.