Bug 1461792 - lk fop succeeds even when lock is not acquired on at least quorum number of bricks
lk fop succeeds even when lock is not acquired on at least quorum number of b...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 1462661 1463104
  Show dependency treegraph
 
Reported: 2017-06-15 06:51 EDT by Pranith Kumar K
Modified: 2017-09-05 13:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1462661 1463104 (view as bug list)
Environment:
Last Closed: 2017-08-23 06:04:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2017-06-15 06:51:36 EDT
Description of problem:
When testing gluster-block we are seeing that even when just one of the bricks is up lk fop is succeeding. This can lead to problems. Fix AFR behavior where lk fop considers quorum count to decide if lk fop succeeds or not.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-06-15 07:20:05 EDT
REVIEW: https://review.gluster.org/17524 (cluster/afr: Implement quorum for lk fop) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Worker Ant 2017-06-18 12:36:29 EDT
REVIEW: https://review.gluster.org/17524 (cluster/afr: Implement quorum for lk fop) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Worker Ant 2017-06-19 01:17:32 EDT
COMMIT: https://review.gluster.org/17524 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 45ebcf7009f549f022c36b4d537eeac62ecfd020
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jun 12 22:06:18 2017 +0530

    cluster/afr: Implement quorum for lk fop
    
    Problem:
    At the moment when we have replica 3 or arbiter setup, even when
    lk succeeds on just one brick we give success to application which
    is wrong
    
    Fix:
    Consider quorum-number of successes as success when quorum is enabled.
    
    BUG: 1461792
    Change-Id: I5789e6eb5defb68f8a0eb9cd594d316f5cdebaea
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/17524
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
Comment 4 Shyamsundar 2017-09-05 13:34:18 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.