Bug 1462661 - lk fop succeeds even when lock is not acquired on at least quorum number of bricks
lk fop succeeds even when lock is not acquired on at least quorum number of b...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.11
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1461792 1463104
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-19 04:14 EDT by Pranith Kumar K
Modified: 2017-06-28 14:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.11.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1461792
Environment:
Last Closed: 2017-06-28 14:32:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2017-06-19 04:14:57 EDT
+++ This bug was initially created as a clone of Bug #1461792 +++

Description of problem:
When testing gluster-block we are seeing that even when just one of the bricks is up lk fop is succeeding. This can lead to problems. Fix AFR behavior where lk fop considers quorum count to decide if lk fop succeeds or not.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-06-15 07:20:05 EDT ---

REVIEW: https://review.gluster.org/17524 (cluster/afr: Implement quorum for lk fop) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Worker Ant on 2017-06-18 12:36:29 EDT ---

REVIEW: https://review.gluster.org/17524 (cluster/afr: Implement quorum for lk fop) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Worker Ant on 2017-06-19 01:17:32 EDT ---

COMMIT: https://review.gluster.org/17524 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 45ebcf7009f549f022c36b4d537eeac62ecfd020
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jun 12 22:06:18 2017 +0530

    cluster/afr: Implement quorum for lk fop
    
    Problem:
    At the moment when we have replica 3 or arbiter setup, even when
    lk succeeds on just one brick we give success to application which
    is wrong
    
    Fix:
    Consider quorum-number of successes as success when quorum is enabled.
    
    BUG: 1461792
    Change-Id: I5789e6eb5defb68f8a0eb9cd594d316f5cdebaea
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/17524
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
Comment 1 Worker Ant 2017-06-20 03:02:32 EDT
REVIEW: https://review.gluster.org/17578 (cluster/afr: Implement quorum for lk fop) posted (#1) for review on release-3.11 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Worker Ant 2017-06-20 09:49:27 EDT
COMMIT: https://review.gluster.org/17578 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 6945c9b3dc3afd290ee12cd5f90a6c538b2aaf14
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jun 12 22:06:18 2017 +0530

    cluster/afr: Implement quorum for lk fop
    
    Problem:
    At the moment when we have replica 3 or arbiter setup, even when
    lk succeeds on just one brick we give success to application which
    is wrong
    
    Fix:
    Consider quorum-number of successes as success when quorum is enabled.
    
     >BUG: 1461792
     >Change-Id: I5789e6eb5defb68f8a0eb9cd594d316f5cdebaea
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: https://review.gluster.org/17524
     >Smoke: Gluster Build System <jenkins@build.gluster.org>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
     >Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    
    BUG: 1462661
    Change-Id: I5789e6eb5defb68f8a0eb9cd594d316f5cdebaea
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/17578
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 3 Shyamsundar 2017-06-28 14:32:55 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.1, please open a new bug report.

glusterfs-3.11.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-June/000074.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.