Bug 1461799 - Migration of the database from 5.7 to 5.8 cannot run from a dedicated database appliance
Migration of the database from 5.7 to 5.8 cannot run from a dedicated databas...
Status: CLOSED DUPLICATE of bug 1475890
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Documentation (Show other bugs)
5.7.0
All All
medium Severity medium
: GA
: 5.8.4
Assigned To: Dayle Parker
Chris Budzilowicz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 07:01 EDT by Felix Dewaleyne
Modified: 2018-04-09 01:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-09 01:37:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trace from rake db:migrate --trace (10.08 KB, text/plain)
2017-06-15 07:01 EDT, Felix Dewaleyne
no flags Details

  None (edit)
Description Felix Dewaleyne 2017-06-15 07:01:07 EDT
Created attachment 1288000 [details]
trace from rake db:migrate --trace

Document URL: https://access.redhat.com/documentation/en-us/red_hat_cloudforms/4.5/html/migrating_to_red_hat_cloudforms_4.5/index#preparing_for_migration42

Section Number and Name: section 1.4.1 part 5

Describe the issue: this step cannot run from a dedicated database appliance, which the documentation suggest to upgrade first

Suggestions for improvement: revise the whole section to better document handling of dedicated databases

Additional information: 
the error is due to the fact the database.yml does not exist on dedicated databases.
Comment 2 Andrew Dahms 2018-04-04 20:36:42 EDT
Assigning to Dayle for review.

Dayle - is this something we might have covered in previous work, or is there some clarification we might be able to provide?
Comment 3 Dayle Parker 2018-04-09 01:37:18 EDT
Hi Andrew,

I think this was fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1475890, where a lot of restructuring happened so steps were labelled according to what kind of appliance to run it on in section 1.5:

https://access.redhat.com/documentation/en-us/red_hat_cloudforms/4.5/html/migrating_to_red_hat_cloudforms_4.5/index#migrate_appliances_42-45

Plus, the bug description looks very similar to #1475890, so I'll close this one as a duplicate.

Cheers,
Dayle

*** This bug has been marked as a duplicate of bug 1475890 ***

Note You need to log in before you can comment on or make changes to this bug.