This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1475890 - migrating dedicated databases as documented does not work
migrating dedicated databases as documented does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Documentation (Show other bugs)
5.8.0
All All
unspecified Severity high
: GA
: cfme-future
Assigned To: Dayle Parker
Chris Budzilowicz
:
Depends On:
Blocks: 1483366
  Show dependency treegraph
 
Reported: 2017-07-27 10:38 EDT by Felix Dewaleyne
Modified: 2017-09-12 03:28 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-12 03:28:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3006321 None None None 2017-07-27 10:54 EDT

  None (edit)
Description Felix Dewaleyne 2017-07-27 10:38:05 EDT
Document URL: https://access.redhat.com/documentation/en-us/red_hat_cloudforms/4.5/html/migrating_to_red_hat_cloudforms_4.5/index#migrate_appliances_42-45

Section Number and Name: section 1.5 Migrating from CFME 5.7 to 5.8

Describe the issue: 

if using a dedicated databases, the database configuration files are missing and  migrate cannot be ran from it!

Suggestions for improvement:  we need to add a note "if you are using a dedicated database, run the ruby commands from a worker" or similer.


Additional information: 
this may need to be rephrased / a different section be added to handle dedicated databases. 

dedicatd appliances do not run any evmserverd process and have no REGION file, GUID or database configuration file
Comment 7 luke couzens 2017-08-07 05:39:34 EDT
Hi guys,

So this revision change is not going to work, there are still no migration steps for the dedicated database.

I suggest we just combine this dedicated stuff with the current HA section '1.6', this is exactly how we want to run a migration with a dedicated db. the steps will be identical to these. The only real difference is there is a single dedicated database appliance not multiple for HA.

Just renaming this section to 'Migrating High Availability and Dedicated database Environments from CFME 5.7 to CFME 5.8' should be fine. Then just change the notes to inform everyone that they should follow these steps instead.
Comment 11 luke couzens 2017-08-07 12:07:28 EDT
RFE bug opened for that issue. https://bugzilla.redhat.com/show_bug.cgi?id=1478986
Comment 14 luke couzens 2017-08-23 05:13:53 EDT
Hi Dayle,

I still think renaming/wording section 1.6 is going to be the easiest and best thing to do, perhaps you, Jan and I should have a call and discuss this stuff so we all understand it and can figure out the best way forward.

Thoughts?

Luke
Comment 15 Dayle Parker 2017-08-24 01:17:03 EDT
Hi Luke,

Sounds great -- I'd prefer the simplest way of documenting this too, but would also really like to get a better understanding of these migration scenarios via a call with you and Jan. 

Would next week work? Any day or time in your mornings/my evenings works for me, with the exception of Monday, when I couldn't do too much later than 5pm Brisbane/9am Brno/8am UK time. Feel free to send me an invite for when it's most convenient for you both.

Cheers,
Dayle
Comment 19 Dayle Parker 2017-09-12 03:28:53 EDT
Thanks for your review, Chris!

The 4.5 migration guide has now been republished with these changes:

https://access.redhat.com/documentation/en-us/red_hat_cloudforms/4.5/html-single/migrating_to_red_hat_cloudforms_4.5/

Note You need to log in before you can comment on or make changes to this bug.