Bug 146185 - (IT_76673) RHEL4 U1: Ide-tape drives not available: missing ide-tape driver
RHEL4 U1: Ide-tape drives not available: missing ide-tape driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
: 146186 (view as bug list)
Depends On: 149979
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 15:26 EST by Joshua Giles
Modified: 2009-02-28 12:08 EST (History)
5 users (show)

See Also:
Fixed In Version: RHEL 4 U2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 15:45:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch fixes st0: Error with sense data: Current st0: sense key Illegal Request" errors (2.55 KB, patch)
2005-01-27 17:00 EST, Joshua Giles
no flags Details | Diff

  None (edit)
Description Joshua Giles 2005-01-25 15:26:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
kernel:2.6.9-5
Platform: All with IDE interface
Platform tested: PE600SC
BIOS: =A09
Tape drive: Travan40 (Seagate STT3401A)

OS detects the Tape drive which can be verified by viewing the
hwbrowser or  /etc/sysconfig/hwconf. But none of the device files :
/devhdb
/dev/ht0
/dev/nht0 
are created. 

mt -f /dev/hdb gives the following : /dev/hdb: No such file or directory


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.906

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 4 pre-RC2 (2.6.9-5) with Travan40 Tape drive
2. View the hwbrowser, /etc/sysconfig/hwconf
3. Check the o/p of: 
     a) ls /dev/hdb
     b) mt -f /dev/hdb status 
    

Actual Results:  ide tape drives are not made available for use.

Expected Results:  Autodetection and loading of the ide-scsi or
(preferably) ide-tape driver so that the tape drive is ready for use.  

Additional info:
Comment 1 Dave Jones 2005-01-25 15:28:03 EST
*** Bug 146186 has been marked as a duplicate of this bug. ***
Comment 2 Joshua Giles 2005-01-27 17:00:02 EST
Created attachment 110321 [details]
This patch fixes st0:  Error with sense data: Current st0: sense key Illegal Request" errors

This patch fixes "st0:	Error with sense data: Current st0: sense key Illegal
Request" errors" seen on the ide tape drives on RHEL4.
Comment 3 Amit Bhutani 2005-01-31 16:13:14 EST
Please include this patch for U1.
Comment 4 Dave Jones 2005-02-03 14:00:22 EST
whats the relevance of this patch to this bug ?
I don't see how fixing those errors has anything to do with the lack
of device nodes.

if they are unrelated, can you create a seperate bug please ?

as for the lack of device node - does anything show up in sysfs ?
if not, that would be why udev didnt create anything.
Comment 5 Joshua Giles 2005-02-08 11:42:32 EST
Darn. I wanted to piggyback that bugfix onto this issue.  Oh well, I
opened up a seperate bug 147496 to address the errors seen when
accessing the drive.
Comment 6 Amit Bhutani 2005-02-08 16:03:24 EST
Comment on attachment 110321 [details]
This patch fixes st0:  Error with sense data: Current st0: sense key Illegal Request" errors

Obsoleting this patch as this patch is not relevant to this (original)issue.
This patch has been appended to the correct Bugzilla (#147496)
Comment 7 Amit Bhutani 2005-04-22 15:57:23 EDT
Since the "sense data errors" issue has been opened seperately, I am trying to 
think aloud on what needs to be done to close this issue ? 

The problem in a summary is this:
1) Dell still needs to supports IDE Tape Drives with RHEL 4.
2) CONFIG_BLK_DEV_IDETAPE is not set in RHEL 4 kernel, hence no ide-tape 
module.
3) The workaround is to force load the deprecated "ide-scsi" driver when a 
need to use IDE tape drivers.
4) This is not working either since a simple tar operation using the "ide-
scsi" driver is causing a kernel panic. See bugzilla 149979 for details.

Therefore one of the two have to happen in order to close this issue:
1) Fix Bugzilla 149979. Patch is available. Then based on the "ide-scsi" 
workaround, we can close this issue.
2) Compile module support for "ide-tape" into RHEL 4 in a future Update.

Can someone from RH comment on possible solutions and POR ?
Comment 8 Tom Coughlan 2005-04-28 15:28:14 EDT
Bugzilla 149979 is on the mustfix list for U2. Assuming that happens, it appears
to be a reasonable resolution for this bug. 

I'll mark this bug as depending on 149979.
Comment 9 Joshua Giles 2005-04-29 11:13:33 EDT
Since 149979 fixes the kernel panic this issue is a request to have the ide-
tape driver compiled by default.
Comment 10 Amit Bhutani 2005-05-03 18:56:14 EDT
Comment #8
> Bugzilla 149979 is on the mustfix list for U2. Assuming that happens, it 
appears to be a reasonable resolution for this bug.

Sounds right. Given the "ide-scsi" woes we are experiencing, I have to 
question the reason RH choose to leave the "ide-tape" driver out of RHEL 4 
kernel ? Was it inheritance from upstream or was it Q&A issues or someting 
else ?
Comment 11 Amit Bhutani 2005-05-17 17:40:03 EDT
Can someone from RH respond to the question posted in comment #10 ?
Comment 12 Tom Coughlan 2005-05-18 09:58:41 EDT
There have been plenty of bad experiences with the ide-tape driver (e.g. BZ
104453). ide-scsi was considered the better of the two alternatives, from a
quality and maintainability perspective. 
Comment 13 Amit Bhutani 2005-05-19 10:07:31 EDT
Thanks for the response. We are investigating internally what those "other 
problems" are in ide-tape since that comment was made by someone from Dell in 
comment #9 from BZ 104453.
Comment 14 Amit Bhutani 2005-09-20 15:26:41 EDT
As per the previous agreement, I have closed the It associated with this bug 
since we now have a functional workaround i.e. use the ide-scsi driver. The 
ide-scsi driver kernel panic issue (IT76670 / BZ149979) appears to be resolved 
in U2 Beta.

RH, please close this bug.

Note You need to log in before you can comment on or make changes to this bug.