Bug 1461990 - Glance API v1 is switched off by default as of Red Hat OpenStack Platform 11
Glance API v1 is switched off by default as of Red Hat OpenStack Platform 11
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 11.0 (Ocata)
Assigned To: Don Domingo
RHOS Documentation Team
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 16:40 EDT by Andreas Karis
Modified: 2017-06-28 09:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
As of this release, Glance API V1 is no longer supported or available.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 09:23:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Karis 2017-06-15 16:40:58 EDT
Description of problem:
It is hidden in the release notes:
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html-single/release_notes/
"However, at the time of this release, EC2 API support still depends
on glance V1 API, which Red Hat OpenStack Platform 11 does not
support. This means the EC2 API is not fully operational at this time.
A future update will fix this issue. "


However, the release notes should officially state:
as of OSP 11, glance API v1 is disabled by default
as os OSP 11, Red Hat does not support glance V1 API
Comment 1 Dan Macpherson 2017-06-15 22:30:31 EDT
Andreas,

I'm removing that paragraph from the release notes as the EC2 API feature should now be compatible with newer versions of Glance. See:

https://bugzilla.redhat.com/show_bug.cgi?id=1341170#c26

The paragraph should now be gone from the doc:

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html-single/release_notes/#idm140496060678592

Was there anything else required?
Comment 2 Andreas Karis 2017-06-16 11:49:07 EDT
Hi,

This bug report is not about EC2 API feature. It's about the fact that we do not document that glance V1 API is disabled since OSP 11.

Please add an explicit section in the release notes stating that glance API v1 is disabled and not supported as of OSP 11.

Thanks :-)

- Andresa
Comment 3 Paul Grist 2017-06-27 11:14:25 EDT
Yes, I think the key issue here is it was not clear enough that glance v1 is not available at all.  

Was the proper place to call this out - 3.1.4. Deprecated Functionality?

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html-single/release_notes/#idm140698422716208

Note You need to log in before you can comment on or make changes to this bug.