Bug 1462082 - path for the gdeploy script files in the generated gdeploy conf has to be changed.
Summary: path for the gdeploy script files in the generated gdeploy conf has to be cha...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.10.7-0.0.18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.1.8
: ---
Assignee: Gobinda Das
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-3 RHHI-1.1-Approved-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2017-06-16 07:01 UTC by RamaKasturi
Modified: 2017-12-11 16:29 UTC (History)
5 users (show)

Fixed In Version: cockpit-ovirt-0.10.10-0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-11 16:29:41 UTC
oVirt Team: Gluster
sasundar: ovirt-4.1?
sasundar: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 80887 master MERGED path for the gdeploy script files changed to /usr/share/gdeploy/scripts 2017-08-30 07:56:53 UTC
oVirt gerrit 80895 ovirt-4.2 POST path for the gdeploy script files changed to /usr/share/gdeploy/scripts 2017-09-07 07:22:52 UTC
oVirt gerrit 80947 ovirt-4.1 MERGED path for the gdeploy script files changed to /usr/share/gdeploy/scripts 2017-08-30 11:18:18 UTC
oVirt gerrit 82509 master MERGED path for the gdeploy script files changed to /usr/share/gdeploy/scripts 2017-11-15 08:52:02 UTC
oVirt gerrit 84518 ovirt-4.1 MERGED path for the gdeploy script files changed to /usr/share/gdeploy/scripts 2017-11-27 12:55:58 UTC

Description RamaKasturi 2017-06-16 07:01:43 UTC
Description of problem:
Latest gdeploy(2.0.2) no longer looks at the path '/use/share/ansible/gdeploy/scripts' for gdeploy script files. Hence the path for the script files in the generated gdeploy conf has to be changed to '/usr/share/gdeploy/scripts'


Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.10.7-0.0.18.el7ev.noarch

How reproducible:


Steps to Reproduce:
1. Have ansible2.3,gdeply2.0.2 and latest cockpit-ovirt-dashboard
2. Use the cockpit UI and generate gdeploy conf file for configuring gluster.
3. Once the conf file is generated click on  'Deploy'

Actual results:
configuring gluster fails with the error, due to the fact that it cannot find gdeploy script files at path '/use/share/ansible/gdeploy/scripts'


Expected results:
path of the script files in the generated gdeploy conf file has to be changed.

Additional info:

Comment 1 RamaKasturi 2017-09-12 06:26:46 UTC
Verified and works fine with build cockpit-ovirt-dashboard-0.10.8-2.0.ovirt41.el7ev.noarch


Path of the script files has been changed to "/usr/share/gdeploy/scripts"

Comment 2 SATHEESARAN 2017-09-14 12:00:48 UTC
The fix for this bug is reverted with the effect of this bug - https://bugzilla.redhat.com/show_bug.cgi?id=1491548 - as because the latest gdeploy which carries the associated fix is not yet available.

Making the required changes with bugzilla flags and acks

Comment 3 RamaKasturi 2017-12-01 09:53:53 UTC
Verified and works fine with build cockpit-ovirt-dashboard-0.10.10-0.el7ev.noarch

I see that the path for gdeploy script files in the gdeployConfig.conf has been changed as below.

/usr/share/gdeploy/scripts/grafton-sanity-check.sh

/usr/share/gdeploy/scripts/blacklist_all_disks.sh

/usr/share/gdeploy/scripts/disable-gluster-hooks.sh


Note You need to log in before you can comment on or make changes to this bug.