This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 146220 - No apparent support for HP photosmart 375 and system-config-printer crashes on attempt.
No apparent support for HP photosmart 375 and system-config-printer crashes o...
Status: CLOSED DUPLICATE of bug 144536
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 20:39 EST by Craig Rickle
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 04:28:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Craig Rickle 2005-01-25 20:39:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Console trace produced when system-config-printer processes "New" click: 

# system-config-printer
*** glibc detected *** malloc(): memory corruption: 0x091f3e28 ***
sh: line 1:  6147 Aborted                 perl -e
'ioctl(STDIN,0x84005001,$result);print $result' 2>/dev/null </dev/usb/lp0
Traceback (most recent call last):
  File "/usr/share/printconf/util/addQueue.py", line 439, in
rescan_button_clicked
    self.populate_device_view (force = 1)
  File "/usr/share/printconf/util/addQueue.py", line 468, in
populate_device_view
    self.local_devs = self.parent.conf.scan_local_printer_devices (force)
  File "/usr/share/printconf/util/printconf_conf.py", line 1265, in
scan_local_printer_devices
   
local_printer_devices.device_dict[dev].update(autodetect_usb_printer(dev,
i))
  File "/usr/share/printconf/util/printconf_conf.py", line 1392, in
autodetect_usb_printer
    return { "auto" : auto }
UnboundLocalError: local variable 'auto' referenced before assignment
*** glibc detected *** malloc(): memory corruption: 0x08ce2e28 ***
sh: line 1:  6155 Aborted                 perl -e
'ioctl(STDIN,0x84005001,$result);print $result' 2>/dev/null </dev/usb/lp0
Traceback (most recent call last):
  File "/usr/share/printconf/util/addQueue.py", line 439, in
rescan_button_clicked
    self.populate_device_view (force = 1)
  File "/usr/share/printconf/util/addQueue.py", line 468, in
populate_device_view
    self.local_devs = self.parent.conf.scan_local_printer_devices (force)
  File "/usr/share/printconf/util/printconf_conf.py", line 1265, in
scan_local_printer_devices
   
local_printer_devices.device_dict[dev].update(autodetect_usb_printer(dev,
i))
  File "/usr/share/printconf/util/printconf_conf.py", line 1392, in
autodetect_usb_printer
    return { "auto" : auto }
UnboundLocalError: local variable 'auto' referenced before assignment

EOF


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run "system-config-printer
2. click "New"
3. get stack trace
    

Actual Results:  see above dump.

Expected Results:  Wizard should run.

Additional info:
Comment 1 Tim Waugh 2005-01-26 04:28:17 EST
This line:

*** glibc detected *** malloc(): memory corruption: 0x091f3e28 ***

indicates a bug in the perl interpreter.

*** This bug has been marked as a duplicate of 144536 ***

Note You need to log in before you can comment on or make changes to this bug.