Bug 1462241 - glusterfind: syntax error due to uninitialized variable 'end'
glusterfind: syntax error due to uninitialized variable 'end'
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterfind (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milind Changire
bugs@gluster.org
:
Depends On:
Blocks: 1462753
  Show dependency treegraph
 
Reported: 2017-06-16 09:07 EDT by Milind Changire
Modified: 2017-09-05 13:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1462753 (view as bug list)
Environment:
Last Closed: 2017-09-05 13:34:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2017-06-16 09:07:42 EDT
Description of problem:
syntax error at line #400 in tools/glusterfind/src/changelog.py

Version-Release number of selected component (if applicable):
due to patch: dbdf56a tools/glusterfind: add --end-time option
https://review.gluster.org/17439
Comment 1 Worker Ant 2017-06-16 09:10:54 EDT
REVIEW: https://review.gluster.org/17557 (tools/glusterfind: initialize variable 'end') posted (#1) for review on master by Milind Changire (mchangir@redhat.com)
Comment 2 Worker Ant 2017-06-19 06:10:36 EDT
COMMIT: https://review.gluster.org/17557 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 3011af67734ac1ef0e73775dc265483f2c5dea91
Author: Milind Changire <mchangir@redhat.com>
Date:   Fri Jun 16 18:39:08 2017 +0530

    tools/glusterfind: initialize variable 'end'
    
    Problem:
    syntax error due to uninitialized variable 'end'
    
    Solution:
    set end = -1
    
    Change-Id: Ia8b500e9dd5304d0832e5f594abca0b5b2ab357e
    BUG: 1462241
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: https://review.gluster.org/17557
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
Comment 3 Shyamsundar 2017-09-05 13:34:18 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.