Bug 1462753 - glusterfind: syntax error due to uninitialized variable 'end'
glusterfind: syntax error due to uninitialized variable 'end'
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfind (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Milind Changire
Anil Shah
:
Depends On: 1462241
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-06-19 09:07 EDT by Milind Changire
Modified: 2017-09-21 00:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1462241
Environment:
Last Closed: 2017-09-21 00:59:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Atin Mukherjee 2017-06-20 09:11:49 EDT
downstream patch : https://code.engineering.redhat.com/gerrit/#/c/109519/
Comment 5 Anil Shah 2017-06-27 09:29:06 EDT
Earlier was able to hit this issue, after running after glusterfind pre command.

[root@dhcp46-22 ~]# glusterfind  pre backup4  vol0 /tmp/log4.txt
10.70.46.22 - pre failed: Traceback (most recent call last):
   File "/usr/libexec/glusterfs/glusterfind/changelog.py", line 400, in <module>
     if end == -1:
 NameError: name 'end' is not defined
 10.70.46.22 - pre failed: Traceback (most recent call last):
   File "/usr/libexec/glusterfs/glusterfind/changelog.py", line 400, in <module>
     if end == -1:
 NameError: name 'end' is not defined
====================================

[root@rhs-arch-srv1 glusterfind]# glusterfind  pre s1   newvolume /tmp/log4.txt
Generated output file /tmp/log4.txt


Build verified on build glusterfs-3.8.4-31.el7rhgs.x86_64
Comment 7 errata-xmlrpc 2017-09-21 00:59:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.