Bug 1462254 - Restart of atomic-openshift-node service terminates pod glusterfs mount
Restart of atomic-openshift-node service terminates pod glusterfs mount
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.5.1
x86_64 Linux
unspecified Severity high
: ---
: 3.5.z
Assigned To: Humble Chirammal
Jianwei Hou
: NeedsTestCase, Reopened
Depends On: 1423640 1424680 1472370 1472372
Blocks: 1466217
  Show dependency treegraph
 
Reported: 2017-06-16 10:05 EDT by Humble Chirammal
Modified: 2017-07-18 11:05 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1423640
: 1466217 (view as bug list)
Environment:
Last Closed: 2017-07-11 06:47:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1640 normal SHIPPED_LIVE OpenShift Container Platform 3.5 and 3.4 bug fix update 2017-07-11 10:47:16 EDT

  None (edit)
Comment 1 Humble Chirammal 2017-06-16 12:40:03 EDT
The OCP 3.5 backport PR # https://github.com/openshift/ose/pull/789
Comment 2 Humble Chirammal 2017-06-22 03:35:18 EDT
The subjected patch has been merged in OCP 3.5 tree.
Comment 3 Jianwei Hou 2017-06-29 04:00:52 EDT
Waiting on https://bugzilla.redhat.com/show_bug.cgi?id=1423640
Comment 4 Jianwei Hou 2017-06-29 05:23:14 EDT
Tested on openshift v3.5.5.28

I have verified the auto_unmount option is merged in openshift code. Gluster Storage team will ensure auto_unmount fixes the issue. From OpenShift perspective, this is verified.
Comment 6 errata-xmlrpc 2017-07-11 06:47:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1640

Note You need to log in before you can comment on or make changes to this bug.