Bug 1462318 - The pk12util man page shouldn't list algorithms that cannot be used for exporting PKCS#12 files
Summary: The pk12util man page shouldn't list algorithms that cannot be used for expor...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nss
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Daiki Ueno
QA Contact: Hubert Kario
URL:
Whiteboard:
Depends On: 1498182
Blocks: rhel7-nss-pkcs12
TreeView+ depends on / blocked
 
Reported: 2017-06-16 17:42 UTC by Hubert Kario
Modified: 2018-04-10 09:46 UTC (History)
4 users (show)

Fixed In Version: nss-3.34.0-0.1.beta1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:44:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0679 None None None 2018-04-10 09:46:03 UTC
Red Hat Bugzilla 1384147 None None None Never
Mozilla Foundation 1406891 None None None 2017-10-25 16:29:08 UTC

Internal Links: 1384147

Description Hubert Kario 2017-06-16 17:42:29 UTC
Description of problem:
See bug 1384147, all the names starting with "PKCS" do not work, either causing export abort or creating unencrypted file

Version-Release number of selected component (if applicable):
nss-3.28.4-8.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. See bug 1384147

Actual results:
Export doesn't work

Expected results:
Export is successful, files are encrypted

Additional info:
The names are highly inconsistent, either providing consistent aliases or documenting what they actually mean in the man page is also necessary.

Comment 17 errata-xmlrpc 2018-04-10 09:44:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0679


Note You need to log in before you can comment on or make changes to this bug.