Bug 1498182 - pk12util man page does not document behaviour of tool
Summary: pk12util man page does not document behaviour of tool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nss
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Daiki Ueno
QA Contact: Hubert Kario
URL:
Whiteboard:
Depends On:
Blocks: 1462318
TreeView+ depends on / blocked
 
Reported: 2017-10-03 16:12 UTC by Hubert Kario
Modified: 2018-04-10 09:46 UTC (History)
4 users (show)

Fixed In Version: nss-3.34.0-0.1.beta1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:46:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0679 None None None 2018-04-10 09:46:48 UTC
Mozilla Foundation 1406891 None None None 2017-10-09 11:25:30 UTC

Description Hubert Kario 2017-10-03 16:12:19 UTC
Description of problem:
pk12util specifies cipher names that do not work (e.g. RC5), the names of ciphers are not correct (most of the PBES1 ciphers) and the type of ciphers is incorrect (e.g. 3DES and RC4 are not PBES2).

Version-Release number of selected component (if applicable):
nss-3.28.4-15.el7_4

How reproducible:
Always

Steps to Reproduce:
1. inspect pk12util man page
2. try using pk12util to export keys or certificates with the ciphers specified in the man page
3. inspect DER encoding to verify if the tool followed parameters

Actual results:
pk12util does not follow man page description

Expected results:
pk12util behaves the way it is documented in the man page

Additional info:

Comment 11 errata-xmlrpc 2018-04-10 09:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0679


Note You need to log in before you can comment on or make changes to this bug.