Bug 146239 - X11 crashes applications ov SSH-forwarded DISPLAY
X11 crashes applications ov SSH-forwarded DISPLAY
Status: CLOSED DUPLICATE of bug 137685
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 05:29 EST by Francois-Xavier 'FiX' KOWALSKI
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 02:46:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Francois-Xavier 'FiX' KOWALSKI 2005-01-26 05:29:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041208 Firefox/1.0

Description of problem:
I am logged onto an fc3/i686 (2xPIII).  I log onto a distant machine,
with X11Forward & ForwardAgent on in my /etc/ssh/ssh_config.  Once
logged on the distant machine (sample is for a rhel3/ia64, bit it
happens with any machine), DISPLAY is correctly redirected.

When I run xterm or gedit from this remote display, things work fine.
 Some other GNOME applications (e.g. op_visualize) crash the X11 display.

op_visalize: when I click the menubar "File" button
emacs : when I click the "New file" button in the toolbar.

command log:

[fxk@tarifa1 fxk]% ssh root@conjnor.grenoble.hp.com 
root@conjnor.grenoble.hp.com's password: 
Last login: Wed Jan 26 11:21:34 2005 from tarifa1.grenoble.hp.com
[root@conjnor root]# echo $DISPLAY
localhost:14.0
[root@conjnor root]# xterm
[root@conjnor root]# gedit 
[root@conjnor root]# op_visualise 
The program 'op_visualise' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 789 error_code 3 request_code 38 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)
[root@conjnor root]# 

[root@conjnor root]# emacs
X protocol error: BadWindow (invalid Window parameter) on protocol
request 38
[root@conjnor root]# 



Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21 openssh-server-3.9p1-7

How reproducible:
Always

Steps to Reproduce:
See above.

Actual Results:  Remote X11 application with redirected DISPLAY crash.

Expected Results:  X11 applicatiom should remain up.

Additional info:

This problem does neither occur with FC2 not FC1 (which where kept
up2date until I upgrade my FC1 to FC3 recently)
Comment 1 Sitsofe Wheeler 2005-01-27 18:31:11 EST
Does using ssh -Y help? If so it looks like you have been caught out by the "ssh
-X is now ssh -Y" change. (If -Y does help you can read more about the change in
bug #141515 )
Comment 2 Mike A. Harris 2005-02-02 15:40:13 EST
Yes, this is due to "ssh -X" being changed by openssh.org to
now be "ssh -Y", so unless you reconfigure ssh manually, remote
X applications will not run properly unless they handle the
X-SECURITY extension properly.  Most applications do not, and so
the default ssh configuration out of the box is not suitable
for running remote X applications, until you reconfigure it
to change the default to forwarding untrusted clients also, 
or invoke it with -Y.

Reassigning to openssh component.
Comment 3 Tomas Mraz 2005-02-03 02:46:15 EST

*** This bug has been marked as a duplicate of 137685 ***

Note You need to log in before you can comment on or make changes to this bug.