Bug 1462517 - Failed to install v3.5 on mix env rpm master plus atomic node
Summary: Failed to install v3.5 on mix env rpm master plus atomic node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.z
Assignee: Russell Teague
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks: 1466501
TreeView+ depends on / blocked
 
Reported: 2017-06-18 11:50 UTC by Anping Li
Modified: 2017-12-14 21:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In some mixed-node environments, it is possible that host facts were not collected for containerized hosts causing a conditional to fail due. A conditional was added to allow the check to complete correctly.
Clone Of:
: 1466501 (view as bug list)
Environment:
Last Closed: 2017-12-14 21:01:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
The inventory file and logs (1020.00 KB, application/x-tar)
2017-06-18 11:50 UTC, Anping Li
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3438 normal SHIPPED_LIVE OpenShift Container Platform 3.6 and 3.5 bug fix and enhancement update 2017-12-15 01:58:11 UTC

Description Anping Li 2017-06-18 11:50:23 UTC
Created attachment 1288835 [details]
The inventory file and logs

Description of problem:
When I installed OCP 3.5 on mix Env(RHLE master + Atomic node). Evaluate oo_containerized_master_nodes failed 


Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.5.82-1.git.0.e3e25f6.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.install OCP v3.5

Actual results:
PLAY [Evaluate node groups] ****************************************************

TASK [setup] *******************************************************************
ok: [localhost]

TASK [Evaluate oo_containerized_master_nodes] **********************************
skipping: [localhost] => (item=openshift-225.lab.eng.nay.redhat.com)  => {
    "changed": false,
    "item": "openshift-225.lab.eng.nay.redhat.com",
    "skip_reason": "Conditional check failed",
    "skipped": true
}
fatal: [localhost]: FAILED! => {
    "failed": true
}

MSG:

The conditional check 'hostvars[item].openshift.common is defined and hostvars[item].openshift.common.is_containerized | bool and (item in groups.oo_nodes_to_config and item in groups.oo_masters_to_config)' failed. The error was: error while evaluating conditional (hostvars[item].openshift.common is defined and hostvars[item].openshift.common.is_containerized | bool and (item in groups.oo_nodes_to_config and item in groups.oo_masters_to_config)): 'dict object' has no attribute 'openshift'

The error appears to have been in '/usr/share/ansible/openshift-ansible/playbooks/common/openshift-node/config.yml': line 28, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
  - name: Evaluate oo_containerized_master_nodes
    ^ here


NO MORE HOSTS LEFT *************************************************************
        to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/config.retry

Expected results:


Additional info:

Comment 1 Russell Teague 2017-06-19 14:53:26 UTC
Proposed: https://github.com/openshift/openshift-ansible/pull/4494

Comment 2 Russell Teague 2017-06-20 19:06:40 UTC
Merged: https://github.com/openshift/openshift-ansible/pull/4494

Comment 3 Russell Teague 2017-06-27 12:22:15 UTC
Patch in >= openshift-ansible-3.5.84-1

Comment 4 Anping Li 2017-06-28 08:35:48 UTC
The installation success with openshift-ansible:v3.5.89

Comment 7 errata-xmlrpc 2017-12-14 21:01:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3438


Note You need to log in before you can comment on or make changes to this bug.