This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1466501 - [3.4] Failed to install v3.4 on mix env rpm master plus atomic node
[3.4] Failed to install v3.4 on mix env rpm master plus atomic node
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.4.z
Assigned To: Russell Teague
Anping Li
:
Depends On: 1462517
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 16:10 EDT by Ryan Howe
Modified: 2017-07-27 14:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In some mixed-node environments, it is possible that host facts were not collected for containerized hosts causing a conditional to fail due. A conditional was added to allow the check to complete correctly.
Story Points: ---
Clone Of: 1462517
Environment:
Last Closed: 2017-07-27 14:02:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2017-06-29 16:10:41 EDT
Backport to 3.4 for commit.
 
   https://github.com/openshift/openshift-ansible/pull/4494/commits/132a2e292b2686e96a20ad9f4797a28e6557dfe9

+++ This bug was initially created as a clone of Bug #1462517 +++

Description of problem:
When I installed OCP 3.5 on mix Env(RHLE master + Atomic node). Evaluate oo_containerized_master_nodes failed 


Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.5.82-1.git.0.e3e25f6.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.install OCP v3.5

Actual results:
PLAY [Evaluate node groups] ****************************************************

TASK [setup] *******************************************************************
ok: [localhost]

TASK [Evaluate oo_containerized_master_nodes] **********************************
skipping: [localhost] => (item=openshift-225.lab.eng.nay.redhat.com)  => {
    "changed": false,
    "item": "openshift-225.lab.eng.nay.redhat.com",
    "skip_reason": "Conditional check failed",
    "skipped": true
}
fatal: [localhost]: FAILED! => {
    "failed": true
}

MSG:

The conditional check 'hostvars[item].openshift.common is defined and hostvars[item].openshift.common.is_containerized | bool and (item in groups.oo_nodes_to_config and item in groups.oo_masters_to_config)' failed. The error was: error while evaluating conditional (hostvars[item].openshift.common is defined and hostvars[item].openshift.common.is_containerized | bool and (item in groups.oo_nodes_to_config and item in groups.oo_masters_to_config)): 'dict object' has no attribute 'openshift'

The error appears to have been in '/usr/share/ansible/openshift-ansible/playbooks/common/openshift-node/config.yml': line 28, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
  - name: Evaluate oo_containerized_master_nodes
    ^ here


NO MORE HOSTS LEFT *************************************************************
        to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/config.retry

Expected results:


Additional info:

--- Additional comment from Russell Teague on 2017-06-19 10:53:26 EDT ---

Proposed: https://github.com/openshift/openshift-ansible/pull/4494

--- Additional comment from Russell Teague on 2017-06-20 15:06:40 EDT ---

Merged: https://github.com/openshift/openshift-ansible/pull/4494

--- Additional comment from Russell Teague on 2017-06-27 08:22:15 EDT ---

Patch in >= openshift-ansible-3.5.84-1

--- Additional comment from Anping Li on 2017-06-28 04:35:48 EDT ---

The installation success with openshift-ansible:v3.5.89
Comment 1 Russell Teague 2017-06-29 18:24:25 EDT
Proposed: https://github.com/openshift/openshift-ansible/pull/4652
Comment 3 Anping Li 2017-07-06 05:44:32 EDT
Waiting for v3.5 puddles.
Comment 5 Anping Li 2017-07-07 01:56:16 EDT
The mix Env can be installed by v3.4.113
Comment 7 errata-xmlrpc 2017-07-27 14:02:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1810

Note You need to log in before you can comment on or make changes to this bug.