Bug 1463250 - with AFR now making both nodes to return UUID for a file will result in georep consuming more resources
with AFR now making both nodes to return UUID for a file will result in geore...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.11
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1462790 1487647
Blocks: 1315781 glusterfs-3.11.1 1462693
  Show dependency treegraph
 
Reported: 2017-06-20 08:39 EDT by Pranith Kumar K
Modified: 2017-09-01 09:31 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.11.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1462790
Environment:
Last Closed: 2017-06-28 14:32:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Pranith Kumar K 2017-06-20 08:44:30 EDT
Description of problem
======================
Previously when a read is requested, AFR was returning only one uuid out of the two replica bricks, but this meant that when a rebalance was triggered only one brick participating and hence load balancing was missing.
This problem was fixed with BZ#1315781 - AFR returns the node uuid of the same node for every file in the replica

However this fix didn't consider other scenarios and consumers of this facility.
for eg, georep too was relying on this service from AFR, and now with this service, it means that georep will be served by both replica bricks and hence syncing of data can happen twice for the same data. Now instead of one brick being passive and other being active, both turn active and hence lead to unnecessary resource utilization(eg CPU)
Comment 2 Worker Ant 2017-06-22 07:40:19 EDT
REVIEW: https://review.gluster.org/17602 (cluster/afr: Returning single and list of node uuids from AFR) posted (#1) for review on release-3.11 by Karthik U S (ksubrahm@redhat.com)
Comment 3 Worker Ant 2017-06-22 13:06:27 EDT
REVIEW: https://review.gluster.org/17615 (cluster/ec: Node uuid xattr support update for EC) posted (#1) for review on release-3.11 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Worker Ant 2017-06-22 16:55:02 EDT
COMMIT: https://review.gluster.org/17602 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 63be8940a73cc92b54e8cee20df5df19bdb9daee
Author: karthik-us <ksubrahm@redhat.com>
Date:   Mon Jun 19 19:54:36 2017 +0530

    cluster/afr: Returning single and list of node uuids from AFR
    
    Problem:
    The change in afr to return list of node uuids was causing problems
    with geo-rep.
    
    Fix:
    This patch will allow to get the single node uuid as it was doing
    before with the key "GF_XATTR_NODE_UUID_KEY", and will also allow
    to get the list of node uuids by using a new key
    "GF_XATTR_LIST_NODE_UUIDS_KEY". This will solve the problem with
    geo-rep and any other feature which were depending on this.
    
    > Change-Id: I09885dac6dfca127be94b708470c8c2941356f9a
    > BUG: 1462790
    > Signed-off-by: karthik-us <ksubrahm@redhat.com>
    > Reviewed-on: https://review.gluster.org/17576
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    > Reviewed-by: Kotresh HR <khiremat@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>
    
    (cherry picked from commit 475ec9928ef96b63a0bfa859a9ae68709275033c)
    
    Change-Id: I6f6e8320a1eb5909ef601e23f8a8d3499807e319
    BUG: 1463250
    Signed-off-by: karthik-us <ksubrahm@redhat.com>
    Reviewed-on: https://review.gluster.org/17602
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 5 Worker Ant 2017-06-22 23:07:28 EDT
REVIEW: https://review.gluster.org/17615 (cluster/ec: Node uuid xattr support update for EC) posted (#2) for review on release-3.11 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Worker Ant 2017-06-26 06:32:35 EDT
COMMIT: https://review.gluster.org/17615 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 91c44b41654ae10a2278ee8c494910a46196077a
Author: Sunil Kumar Acharya <sheggodu@redhat.com>
Date:   Wed Jun 21 16:37:09 2017 +0530

    cluster/ec: Node uuid xattr support update for EC
    
            Backport of https://review.gluster.org/17594
    
    Problem:
    The change in EC to return list of node uuids for
    GF_XATTR_NODE_UUID_KEY was causing problems with
    geo-rep.
    
    Fix:
    This patch will allow to get the single node uuid
    as it was doing before with the key
    "GF_XATTR_NODE_UUID_KEY", and will also allow to get
    the list of node uuids by using a new key
    "GF_XATTR_LIST_NODE_UUIDS_KEY". This will solve
    the problem with geo-rep and any other features which
    were depending on this.
    
    BUG: 1463250
    Change-Id: I2d9214a9658d4a41a3d6de08600884d2bda5f3eb
    Signed-off-by: Sunil Kumar Acharya <sheggodu@redhat.com>
    Reviewed-on: https://review.gluster.org/17615
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 7 Worker Ant 2017-06-26 07:02:50 EDT
REVIEW: https://review.gluster.org/17627 (cluster/rebalance: Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols.) posted (#1) for review on release-3.11 by N Balachandran (nbalacha@redhat.com)
Comment 8 Worker Ant 2017-06-26 12:27:11 EDT
COMMIT: https://review.gluster.org/17627 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit f67dbab74a3d0a13a8f7ed31b8cc840c05042913
Author: Susant Palai <spalai@redhat.com>
Date:   Wed Jun 21 17:52:45 2017 +0530

    cluster/rebalance: Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols.
    
    Afr has introduced a new key GF_XATTR_LIST_NODE_UUIDS_KEY,
    through which rebalance will figure out its local subvolumes.(Reference
    bugid=1463250)
    
    key: GF_XATTR_NODE_UUID_KEY will continue to serve it's old
    purpose of returning the first afr chiild.
    
    test: prove tests/basic/distribute/rebal-all-nodes-migrate.t
    
    > BUG: 1463648
    > Signed-off-by: Susant Palai <spalai@redhat.com>
    
    Change-Id: I4d602feda2a05b29d2210c712a07a4ac6b8bc112
    BUG: 1463250
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: https://review.gluster.org/17627
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 9 Shyamsundar 2017-06-28 14:32:55 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.1, please open a new bug report.

glusterfs-3.11.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-June/000074.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.