Bug 1463264 - Cannot add RHV 4.1 as Compute Resource
Summary: Cannot add RHV 4.1 as Compute Resource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - RHEV
Version: 6.2.9
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Sanket Jagtap
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-20 13:07 UTC by Petr Kubica
Modified: 2019-06-13 21:25 UTC (History)
6 users (show)

Fixed In Version: https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=530185, rubygem-rbovirt-0.0.38-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1480361 (view as bug list)
Environment:
Last Closed: 2017-09-25 18:59:44 UTC


Attachments (Terms of Use)
additional log (22.96 KB, text/plain)
2017-06-20 13:07 UTC, Petr Kubica
no flags Details
Rhv4 (49.22 KB, image/png)
2017-08-28 07:18 UTC, Sanket Jagtap
no flags Details
Rhv4 added (23.26 KB, image/png)
2017-08-28 07:21 UTC, Sanket Jagtap
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2803 normal SHIPPED_LIVE Satellite 6.2.12 bug fix update 2017-10-12 19:22:49 UTC

Description Petr Kubica 2017-06-20 13:07:34 UTC
Created attachment 1289643 [details]
additional log

Description of problem:

Error in UI:
Unable to save
undefined method `+' for nil:NilClass

foreman-tail:
==> /var/log/httpd/foreman-ssl_access_ssl.log <==
10.34.130.218 - - [20/Jun/2017:14:24:01 +0200] "PUT /compute_resources/test_connection HTTP/1.1" 200 3208 "https://[FILTERED_SAT_FQDN]/compute_resources/new" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0"

==> /var/log/foreman/production.log <==
2017-06-20 14:24:01 742fbe3c [app] [I] Started PUT "/compute_resources/test_connection" for 10.34.130.218 at 2017-06-20 14:24:01 +0200
2017-06-20 14:24:01 742fbe3c [app] [I] Processing by ComputeResourcesController#test_connection as */*
2017-06-20 14:24:01 742fbe3c [app] [I]   Parameters: {"utf8"=>"✓", "authenticity_token"=>"XXWwXx1CuapoOKNpu8tk9zgLnl1GcQi9vxdRw5Qzp6I=", "compute_resource"=>{"name"=>"[FILTERED_RHV_FQDN]", "provider"=>"Ovirt", "description"=>"", "url"=>"https://[FILTERED_RHV_FQDN]/ovirt-engine/api", "user"=>"admin@internal", "password"=>"[FILTERED]", "public_key"=>"-----BEGIN CERTIFICATE-----\r\nMIIEIzCCAwugAwIBAgICEAAwDQYJKoZIhvcNAQELBQAwZzELMAkGA1UEBhMCVVMxJDAiBgNVBAoT\r\nG3JoZXYubGFiLmVuZy5icnEucmVkaGF0LmNvbTEyMDAGA1UEAxMpcmgtdm0wMi5yaGV2LmxhYi5l\r\nbmcuYnJxLnJlZGhhdC5jb20uMjQ1NjYwHhcNMTcwNjE5MTEwNTEzWhcNMjcwNjE4MTEwNTEzWjBn\r\nMQswCQYDVQQGEwJVUzEkMCIGA1UEChMbcmhldi5sYWIuZW5nLmJycS5yZWRoYXQuY29tMTIwMAYD\r\nVQQDEylyaC12bTAyLnJoZXYubGFiLmVuZy5icnEucmVkaGF0LmNvbS4yNDU2NjCCASIwDQYJKoZI\r\nhvcNAQEBBQADggEPADCCAQoCggEBALGs+v1BfXs34V9d713DuTmEzM+niBMCygChOmibaKOi3olo\r\nIZy4jYJpT8INkwkcA9Qyen9oFRalfMaJKCbZo6GN1JbgnoqhOazGSb9HAWsyhxX9bvUzdrbjViLg\r\nDr4fS2r/LJGhyNktCvxooinHzhCReO9ppQ0e3HteABrS4Pe2PwQke7QLBzBshE8cxTnpCcTW0dEV\r\ngFV/zr+h+oADcJmkWMsXLST5wn2JfbAmoql8X0aEtbkJtDK4tPtig2M5b74Cfs8EGHFZ6eOArjbI\r\naiidzb4ZfYzisTCExTzU3v/B3MqAB3AVfiHxVE8U9VgYPg0Dr+AWkhU4KcXuJ2Fn/i0CAwEAAaOB\r\n2DCB1TAdBgNVHQ4EFgQUJsIg4EwpQL4cNqc0/vMuEYT6iRswgZIGA1UdIwSBijCBh4AUJsIg4Ewp\r\nQL4cNqc0/vMuEYT6iRuha6RpMGcxCzAJBgNVBAYTAlVTMSQwIgYDVQQKExtyaGV2LmxhYi5lbmcu\r\nYnJxLnJlZGhhdC5jb20xMjAwBgNVBAMTKXJoLXZtMDIucmhldi5sYWIuZW5nLmJycS5yZWRoYXQu\r\nY29tLjI0NTY2ggIQADAPBgNVHRMBAf8EBTADAQH/MA4GA1UdDwEB/wQEAwIBBjANBgkqhkiG9w0B\r\nAQsFAAOCAQEAVmPZr0xk8d4k9N73pjJm51afr1IJixD7ejDaEu/volMXjxPGIg0agfzGp2BJ+CJ8\r\nf1MeLSk7zvPontG4bFocSNARptu8SLTO7CEPBDCDPH6Xzyu4BJGiU556+N1WLMbMm9J5iO+TCzvZ\r\nv+OOGoEuYpvTJQgZ6SsFKky4L0c2cE31QYH8/md1hcPf2sx0UE3v0IP/qpfLtl8+bFq8Akz0PiWN\r\naqz6q5Oun0X7ys8WeDsNQzYRkkUBoubvV4QOzFAgzGw/pkqyJP2fSg+xtwu4wuFRBcWg2aDDVnku\r\n8SfhHt8hMnrFDSnFOY334Nmn1ITBw/GEuq7wr50kiM6/IB86zA==\r\n-----END CERTIFICATE-----\r\n", "location_ids"=>["", "2"], "organization_ids"=>["", "1"]}, "fakepassword"=>"[FILTERED]", "cr_id"=>"null"}
2017-06-20 14:24:01 742fbe3c [app] [I] CR_ID IS null
2017-06-20 14:24:01 742fbe3c [app] [I]   Rendered compute_resources/form/_ovirt.html.erb (276.0ms)
2017-06-20 14:24:01 742fbe3c [app] [I]   Rendered taxonomies/_loc_org_tabs.html.erb (6.1ms)
2017-06-20 14:24:01 742fbe3c [app] [I]   Rendered compute_resources/_form.html.erb (287.6ms)
2017-06-20 14:24:01 742fbe3c [app] [I] Completed 200 OK in 435ms (Views: 287.0ms | ActiveRecord: 4.2ms)


Version-Release number of selected component (if applicable):
rhv 4.1.3.4-0.1.el7
satellite 6.2.9

How reproducible:
always

Steps to Reproduce:
1. Enter valid information for adding new rhev compute resource
1. Click on button "Load Datacenters" or try to Submit 

Actual results:
Cannot add RHV 4.1 as compute resource

Additional info:
Added log provided in browser

Comment 4 Bryan Kearney 2017-08-08 19:27:23 UTC
This was a miss in the errata. Aligning to 6.2.12 for inclusion.

Comment 7 Sanket Jagtap 2017-08-28 07:18:31 UTC
Created attachment 1318952 [details]
Rhv4

Build: Satellite 6.2.12 snap1

rpm -qa | grep ovirt
tfm-rubygem-rbovirt-0.0.38.1-1.el7sat.noarch
foreman-ovirt-1.11.0.85-1.el7sat.noarch

Rhv4 Version- Version 4.0.6.3-0.1.el7ev

The RHV Compute Resource was added successfully.
PFA

Comment 8 Sanket Jagtap 2017-08-28 07:21:09 UTC
Created attachment 1318953 [details]
Rhv4 added

Comment 10 errata-xmlrpc 2017-09-25 18:59:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2803


Note You need to log in before you can comment on or make changes to this bug.