Bug 146329 - rpmbuild's check-files script does not check for unpackages symbolic links
Summary: rpmbuild's check-files script does not check for unpackages symbolic links
Status: CLOSED DUPLICATE of bug 108778
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-27 01:34 UTC by Mark Hatle
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-02 15:08:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to implement behavior. (1.26 KB, patch)
2005-01-27 01:38 UTC, Mark Hatle
no flags Details | Diff

Description Mark Hatle 2005-01-27 01:34:15 UTC
Description of problem:
The check-files script does not check for unpackages symbolic links. 
This is useful if you are packaging a lot of libraries that create
symlinks.

Comment 1 Mark Hatle 2005-01-27 01:38:48 UTC
Created attachment 110279 [details]
Patch to implement behavior.

The patch consists of two parts, a chance to check-files and a change to the
build/files.c to provide a list of files including symbolic links to the
script.

Comment 2 Mark Hatle 2005-04-02 15:08:45 UTC
This has been fixed in RPM 4.4 branch.  It was corrected as bug 108778.

*** This bug has been marked as a duplicate of 108778 ***


Note You need to log in before you can comment on or make changes to this bug.