Bug 1463648 - Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols
Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susant Kumar Palai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 08:22 EDT by Susant Kumar Palai
Modified: 2017-09-05 13:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 13:34:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susant Kumar Palai 2017-06-21 08:22:27 EDT
Description of problem:
As part of fix for bug: https://bugzilla.redhat.com/show_bug.cgi?id=1463250, afr introduced a new key GF_XATTR_LIST_NODE_UUIDS_KEY  through which rebalance will figure out its local subvolumes. 

key: GF_XATTR_NODE_UUID_KEY will continue to serve it's old purpose of returning the first afr chiild.
Comment 1 Worker Ant 2017-06-21 08:27:14 EDT
REVIEW: https://review.gluster.org/17595 (cluster/rebalance: Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols.) posted (#1) for review on master by Susant Palai (spalai@redhat.com)
Comment 2 Worker Ant 2017-06-23 01:31:50 EDT
REVIEW: https://review.gluster.org/17595 (cluster/rebalance: Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols.) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 3 Nithya Balachandran 2017-06-23 02:25:42 EDT
Patch#2 also contains changes to get tier to use the new GF_XATTR_LIST_NODE_UUIDS_KEY to determine which node should migrate the file.
Comment 4 Worker Ant 2017-06-23 07:24:52 EDT
REVIEW: https://review.gluster.org/17595 (cluster/rebalance: Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols.) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 5 Worker Ant 2017-06-23 10:13:27 EDT
REVIEW: https://review.gluster.org/17595 (cluster/rebalance: Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols.) posted (#4) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 6 Worker Ant 2017-06-26 06:47:04 EDT
COMMIT: https://review.gluster.org/17595 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 4700c5be55b0e567755b4c8a1a91f33d29c06e6b
Author: Susant Palai <spalai@redhat.com>
Date:   Wed Jun 21 17:52:45 2017 +0530

    cluster/rebalance: Use GF_XATTR_LIST_NODE_UUIDS_KEY to figure out local subvols.
    
    Afr has introduced a new key GF_XATTR_LIST_NODE_UUIDS_KEY,
    through which rebalance will figure out its local subvolumes.(Reference
    bugid=1463250)
    
    key: GF_XATTR_NODE_UUID_KEY will continue to serve it's old
    purpose of returning the first afr chiild.
    
    test: prove tests/basic/distribute/rebal-all-nodes-migrate.t
    
    Change-Id: I4d602feda2a05b29d2210c712a07a4ac6b8bc112
    BUG: 1463648
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: https://review.gluster.org/17595
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 7 Shyamsundar 2017-09-05 13:34:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.