Bug 1463680 - "Invalid parameter transport on Class[Nova::Migration::Libvirt]" notice while scaleout
"Invalid parameter transport on Class[Nova::Migration::Libvirt]" notice while...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
9.0 (Mitaka)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Emilien Macchi
Arik Chernetsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 09:29 EDT by Jaison Raju
Modified: 2018-01-07 05:34 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 12:09:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaison Raju 2017-06-21 09:29:28 EDT
Description of problem:
After upgrade pf undercloud & While scaleout of compute on RHOS9 , stack scaleout fails .

Version-Release number of selected component (if applicable):
[stack@director ~]$ rpm -qa | grep puppet
puppet-3.6.2-2.el7.noarch
openstack-puppet-modules-8.1.13-2.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-6.el7ost.noarch
[stack@director ~]$ rpm -qa | grep tripleo
openstack-tripleo-image-elements-0.9.9-7.el7ost.noarch
openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-57.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-6.el7ost.noarch
python-tripleoclient-2.0.0-14.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-57.el7ost.noarch
openstack-tripleo-common-2.0.0-10.el7ost.noarch
[stack@director ~]$ 


How reproducible:
Always at customer env .

Steps to Reproduce:
1.
2.
3.

Actual results:
overcloud deploy command failes for scale out .

Expected results:
deployment succeeds .

Additional info:

deploy_stderr": "\u001b[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::host'; class ::nova::vncproxy has not been evaluated\u001b[0m\n\u001b[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::vncproxy_protocol'; class ::nova::vncproxy has not been evaluated\u001b[0m\n\u001b[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::port'; class ::nova::vncproxy has not been evaluated\u001b[0m\n\u001b[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::vncproxy_path'; class ::nova::vncproxy has not been evaluated\u001b[0m\n\u001b[1;31mError: Invalid parameter transport on Class[Nova::Migration::Libvirt] at /var/lib/heat-config/heat-config-puppet/6ff2915b-279e-465e-8c70-a51c87feecad.pp:111 on node compute3.stack.rdu2.cee.redhat.com\nWrapped exception:\nInvalid parameter transport\u001b[0m\n\u001b[1;31mError: Invalid parameter transport on Class[Nova::Migration::Libvirt] at /var/lib/heat-config/heat-config-puppet/6ff2915b-279e-465e-8c70-a51c87feecad.pp:111 on node compute3.stack.rdu2.cee.redhat.com\u001b[0m\n

This seems to be similar to https://bugzilla.redhat.com/show_bug.cgi?id=1458334
Comment 2 Alex Schultz 2017-06-21 10:26:12 EDT
Just FYI, this has been seen if there's a bad mix of openstack-puppet-modules and THT packages (check also the updated images). Please make sure you've got the latest as this was part of the CVE fix.
Comment 6 Jaison Raju 2017-06-22 04:58:20 EDT
We upgraded undercloud . THT & OPM on undercloud & OPM on overcloud are latest & same version.

Error: Could not set 'file' on ensure: No such file or directory - /etc/nova/migration/authorized_keys20170622-81701-t48kh1 at 153:/var/lib/heat-config/heat-config-puppet/9909c00a-1dee-4239-8d87-fcf2879a4063.pp\u001b[0m\n\u001b[1;31mError: Cou

I tried with / without 'nova::compute::libvirt::migration_support:' enabled , but that does not change the error .
I am currently trying to create the /etc/nova/migration/ via computepre templates & trying again .
For some reason ssh service is also not allowing login .
Comment 36 Jaison Raju 2017-06-26 07:10:41 EDT
Jun 23 12:07:53 ceph1 os-collect-config: [2017-06-23 12:07:45,309] (heat-config) [DEBUG] Running /var/lib/heat-config/heat-config-script/74ca2717-359a-4f82-aa3c-b56dbf881e26
Jun 23 12:07:53 ceph1 os-collect-config: [2017-06-23 12:07:53,719] (heat-config) [INFO] Started yum_update.sh on server 342d5640-feae-4fc6-9119-85400959d36c at Fri Jun 23 12:07:45 EDT 2017
Jun 23 12:07:53 ceph1 os-collect-config: Manual upgrade of openvswitch - restart in postun detected


This is the timestamp of last update .
Comment 45 Sofer Athlan-Guyot 2017-06-27 14:14:02 EDT
Hi,

this doesn't relate to dfg:upgrade/update, it's just that any change to the overcloud will have a message overcloud UPDATE_FAIL if that change fail.  You would need someone from compute to get better insight.
Comment 52 Ollie Walsh 2017-06-30 12:09:03 EDT
As the original issue was caused by a deploy being run before the overcloud was updated I will close this.

Note You need to log in before you can comment on or make changes to this bug.