Bug 1463746 - Satellite 5.8 Installation Guide mentions Beta and wrong rhn-upgrade pkg version
Satellite 5.8 Installation Guide mentions Beta and wrong rhn-upgrade pkg version
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
580
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Russell Dickenson
Andrew Dahms
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 11:58 EDT by Xixi
Modified: 2017-06-27 11:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-22 00:33:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2017-06-21 11:58:08 EDT
Description of problem:
https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/html-single/installation_guide/

From customer comment on the public Satellite 5.8 FAQ https://access.redhat.com/articles/3073161#comment-1188251:

"The installation guide still has references to '5.8 beta'. Is there a final version to be published?

The chapter 9 section 9.2.2 instruction reference RPMs to be installed depending on whether the system is RHEL 5 or RHEL 6.

/media/cdrom/rhn-upgrade-5.8.0.10-1.el6sat.noarch.rpm /media/cdrom/rhn-upgrade-5.8.0.10-1.el5sat.noarch.rpm

Neither of these exist in the ISO."

Several things to be fixed here:
1) "Beta" needs to be removed now that Satellite 5.8 is GA.
2) the correct rhn-upgrade package is rhn-upgrade-5.8.0.23-1.el6sat.noarch 
3) The rhn-upgrade package does not reside in the Satellite installer ISO but rather the Satellite Channel (or can also be downloaded from Customer Portal Downloads) - for example, from 5.7 install guide https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/5.7/html-single/Installation_Guide/index.html - 
"Obtain Red Hat Satellite Upgrade Package (rhn-upgrade)

    Ensure the Satellite is registered to the Red Hat Satellite Channel.
    Install the rhn-upgrade package with the following command:

    # yum install rhn-upgrade

    This package installs scripts and a comprehensive set of instructions for a Red Hat Satellite upgrade within the /etc/sysconfig/rhn/satellite-upgrade directory. "

Version-Release number of selected component (if applicable):
5.8.0

How reproducible:
always

Steps to Reproduce:
1. visit Instalation Guide https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/html-single/installation_guide/ and grep for "Beta" and "rhn-upgrade"
2.
3.

Actual results:
stuff in several places like:
"** Subscriptions: Subscription providing 'Red Hat Satellite Beta' already attached."
"Click Red Hat Satellite Beta. "
"# yum install /media/cdrom/rhn-upgrade-5.8.0.10-1.el6sat.noarch.rpm"
"# yum install /media/cdrom/rhn-upgrade-5.8.0.10-1.el5sat.noarch.rpm"

Expected results:
no mentions of Beta, correct upgrade instructions and rhn-upgrade version

Additional info:
Comment 1 Xixi 2017-06-21 14:18:29 EDT
(updated Bug Description in-place)

This bug is actually more non-trivial since the upgrade steps are actually incorrect with respect to obtaining the rhn-upgrade package since it's not in the ISO.  Marking as urgent.
Comment 3 Andrew Dahms 2017-06-22 00:32:03 EDT
Looks good to me; moving to VERIFIED.
Comment 4 Andrew Dahms 2017-06-22 00:33:04 EDT
This content is now live on the Customer Portal.

Closing for now, but Xixi - let us know if you feel any additional changes are needed, and we can revisit this bug for you.

Note You need to log in before you can comment on or make changes to this bug.