Bug 1465555 - Satellite 5.8 Installation Guide: document where to get rhn-upgrade pkg for disconnected customers
Satellite 5.8 Installation Guide: document where to get rhn-upgrade pkg for d...
Status: CLOSED DUPLICATE of bug 1465277
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
580
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: satellite-doc-list
satellite-doc-list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 11:32 EDT by Xixi
Modified: 2017-06-27 11:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 11:34:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 11041 None None None 2017-06-27 11:32 EDT

  None (edit)
Description Xixi 2017-06-27 11:32:46 EDT
Description of problem:
https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/html-single/installation_guide/

Got several customer questions on how to get rhn-upgrade for disconnected Satellites (since they can't yum install it from Hosted), would be good to get this included in the docs.

FWIW, I updated this kbase https://access.redhat.com/solutions/11041 ("How to upgrade Red Hat Satellite 5 Server to the most current version?") in response to one of the customers:

"Install the latest rhn-upgrade RPM package on your Red Hat Satellite 5 server, either via `yum install rhn-upgrade` or downloaded manually from Red Hat Customer Portal as follows:

    Go to the Product Downloads section of the Customer Portal
    Choose "Red Hat Satellite"
    Select the desired Product Variant, Version and Architecture to upgrade *from* (i.e. the current version of the Satellite), for example, "Red Hat Satellite", "5.6 for RHEL 6", "x86_64"
    Go to "Packages" tab and search for "upgrade" to find the rhn-upgrade package
    Download and install on the Satelliter server to be upgraded"

Version-Release number of selected component (if applicable):
5.8.0

How reproducible:
always

Steps to Reproduce:
1. visit Instalation Guide https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/html-single/installation_guide/ and grep for "rhn-upgrade"
2.
3.

Actual results:
only steps for getting rhn-upgrade via yum install (connected Satellites)

Expected results:
for disconnected customers, include alternative option to download package directly via Red Hat Customer Portal 

Additional info:

Note You need to log in before you can comment on or make changes to this bug.