Bug 1463751 - Epel invalid metadata
Epel invalid metadata
Status: CLOSED DUPLICATE of bug 1463561
Product: Fedora EPEL
Classification: Fedora
Component: epel-release (Show other bugs)
epel7
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Michael Stahnke
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 12:17 EDT by Michael Mol
Modified: 2017-06-23 23:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 12:25:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Mol 2017-06-21 12:17:55 EDT
Description of problem:

Yum metadata downloads currently fail because of broken epel metadata.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum clean all
2. yum check-update

Actual results:

Updateinfo file is not valid XML: <open file '/var/cache/yum/x86_64/7/epel/gen/updateinfo.xml', mode 'rt' at 0x2737420>

Expected results:

I should see whether or not any packages are available to be updated

Additional info:

This has been going on all morning, starting first hitting my preferred mirror (mirror.math.princeton.edu) at about 9AM UTC-4.
Comment 1 Kevin Fenzi 2017-06-21 12:25:34 EDT

*** This bug has been marked as a duplicate of bug 1463561 ***
Comment 2 Lukas Slebodnik 2017-06-23 03:17:23 EDT
(In reply to Michael Mol from comment #0)
> Updateinfo file is not valid XML: <open file
> '/var/cache/yum/x86_64/7/epel/gen/updateinfo.xml', mode 'rt' at 0x2737420>
> 

(In reply to Kevin Fenzi from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 1463561 ***

Kevin,
I can see the same error on f26 with yum-deprecated. It is not a problem with dnf-2.5. Are repositories fixed also for f26? Or I just need to wait a little bit longer :-) then on f25 and f24
Comment 3 Kevin Fenzi 2017-06-23 23:27:04 EDT
All the repos were fixed the same day the issue occurred. 

You may need to 'dnf clean all' or the like to make sure you don't have the bad repodata cached. Also, if you are not using the (default) metalink for Fedora/epel repos but have manually switched to a baseurl, you will need for that specific mirror to sync up.

Note You need to log in before you can comment on or make changes to this bug.