This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1463561 - system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: A...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0f8f7068888fda0d10393480c7f...
:
: 1463505 1463580 1463582 1463645 1463689 1463751 1464344 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 04:50 EDT by David W. Legg
Modified: 2017-08-14 09:46 EDT (History)
59 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 12:21:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (86.94 KB, text/plain)
2017-06-21 04:50 EDT, David W. Legg
no flags Details
File: cgroup (242 bytes, text/plain)
2017-06-21 04:50 EDT, David W. Legg
no flags Details
File: core_backtrace (6.96 KB, text/plain)
2017-06-21 04:50 EDT, David W. Legg
no flags Details
File: dnf.txt (2.30 MB, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: dso_list (11.13 KB, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: environ (3.51 KB, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: limits (1.29 KB, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: maps (51.40 KB, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: mountinfo (3.36 KB, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: namespaces (102 bytes, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: open_fds (1.84 KB, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: proc_pid_status (1.26 KB, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details
File: var_log_messages (28 bytes, text/plain)
2017-06-21 04:51 EDT, David W. Legg
no flags Details

  None (edit)
Description David W. Legg 2017-06-21 04:50:31 EDT
Description of problem:
$ dnf list openshot --enablerepo=*testing
RPM Fusion for Fedora 25 - Nonfree - Test Updates                                                                                             26 kB/s | 1.2 kB     00:00    
Fedora 25 - x86_64 - Test Updates                                                                                                            4.2 MB/s | 5.1 MB     00:01    
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
Aborted (core dumped)
[daddy@arcturus VOICE]$



Version-Release number of selected component:
system-python-3.5.3-6.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/system-python /usr/bin/dnf list openshot --enablerepo=*testing
crash_function: load_ext
executable:     /usr/libexec/system-python
global_pid:     18150
kernel:         4.11.5-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1001

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 load_ext at /usr/src/debug/hawkey-0.6.4/src/sack.c:354
 #5 hy_sack_load_repo at /usr/src/debug/hawkey-0.6.4/src/sack.c:1049
 #6 load_repo at /usr/src/debug/hawkey-0.6.4/src/python/sack-py.c:455
 #7 PyCFunction_Call at /usr/src/debug/Python-3.5.3/Objects/methodobject.c:98
 #8 do_call at /usr/src/debug/Python-3.5.3/Python/ceval.c:5006
 #9 call_function at /usr/src/debug/Python-3.5.3/Python/ceval.c:4805
 #10 PyEval_EvalFrameEx at /usr/src/debug/Python-3.5.3/Python/ceval.c:3304
 #11 fast_function at /usr/src/debug/Python-3.5.3/Python/ceval.c:4876
 #12 call_function at /usr/src/debug/Python-3.5.3/Python/ceval.c:4803
 #13 PyEval_EvalFrameEx at /usr/src/debug/Python-3.5.3/Python/ceval.c:3304
Comment 1 David W. Legg 2017-06-21 04:50:42 EDT
Created attachment 1289972 [details]
File: backtrace
Comment 2 David W. Legg 2017-06-21 04:50:44 EDT
Created attachment 1289973 [details]
File: cgroup
Comment 3 David W. Legg 2017-06-21 04:50:46 EDT
Created attachment 1289974 [details]
File: core_backtrace
Comment 4 David W. Legg 2017-06-21 04:51:03 EDT
Created attachment 1289975 [details]
File: dnf.txt
Comment 5 David W. Legg 2017-06-21 04:51:05 EDT
Created attachment 1289977 [details]
File: dso_list
Comment 6 David W. Legg 2017-06-21 04:51:07 EDT
Created attachment 1289978 [details]
File: environ
Comment 7 David W. Legg 2017-06-21 04:51:09 EDT
Created attachment 1289979 [details]
File: limits
Comment 8 David W. Legg 2017-06-21 04:51:11 EDT
Created attachment 1289980 [details]
File: maps
Comment 9 David W. Legg 2017-06-21 04:51:13 EDT
Created attachment 1289981 [details]
File: mountinfo
Comment 10 David W. Legg 2017-06-21 04:51:15 EDT
Created attachment 1289982 [details]
File: namespaces
Comment 11 David W. Legg 2017-06-21 04:51:17 EDT
Created attachment 1289983 [details]
File: open_fds
Comment 12 David W. Legg 2017-06-21 04:51:18 EDT
Created attachment 1289984 [details]
File: proc_pid_status
Comment 13 David W. Legg 2017-06-21 04:51:20 EDT
Created attachment 1289985 [details]
File: var_log_messages
Comment 14 David W. Legg 2017-06-21 04:54:25 EDT
The dnf.txt file is an strace -o output file.
Comment 15 Vitaliy Sapronenko 2017-06-21 05:11:11 EDT
Similar problem has been detected:

[vsapronenko@localhost ~]$ dnf info flash-player
RPM Fusion for Fedora 25 - Nonfree - Updates                                                                                                                                                                                                    303  B/s |  37 kB     02:05    
Fedora 25 - x86_64 - Updates                                                                                                                                                                                                                    867 kB/s |  23 MB     00:27    
RPM Fusion for Fedora 25 - Nonfree                                                                                                                                                                                                              1.1 kB/s | 144 kB     02:05    
Fedora 25 - x86_64                                                                                                                                                                                                                              2.1 MB/s |  50 MB     00:23    
RPM Fusion for Fedora 25 - Free                                                                                                                                                                                                                  96 kB/s | 515 kB     00:05    
Fedora 25 - x86_64 - Test Updates                                                                                                                                                                                                               1.4 MB/s | 5.1 MB     00:03    
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
Aborted (збережено знімок оперативної пам’яті)
[vsapronenko@localhost ~]$ dnf info flash-player
Adobe Systems Incorporated                                                                                                                                                                                                                      385  B/s | 1.9 kB     00:05    
RPM Fusion for Fedora 25 - Free - Updates                                                                                                                                                                                                       916 kB/s | 275 kB     00:00    
Copr repo for haguichi owned by ztefn                                                                                                                                                                                                           4.1 kB/s | 2.5 kB     00:00    
google-chrome                                                                                                                                                                                                                                   761  B/s | 3.8 kB     00:05    
PostgreSQL 9.5 25 - x86_64                                                                                                                                                                                                                       31 kB/s | 313 kB     00:09    
Repository for Fedy                                                                                                                                                                                                                             4.8 kB/s | 8.1 kB     00:01    
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
Aborted (збережено знімок оперативної пам’яті)

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/system-python /usr/bin/dnf info flash-player
crash_function: load_ext
executable:     /usr/libexec/system-python
global_pid:     11067
kernel:         4.11.5-200.fc25.x86_64
package:        system-python-3.5.3-6.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         system-python killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 16 Vitaliy Sapronenko 2017-06-21 05:44:36 EDT
Similar problem has been detected:

[vsapronenko@localhost ~]$ sudo dnf upgrade
[sudo] пароль до vsapronenko: 
Copr repo for PyCharm owned by phracek                                                                                                                                                                                                           62 kB/s |  60 kB     00:00    
PostgreSQL 9.5 25 - x86_64                                                                                                                                                                                                                       49 kB/s | 313 kB     00:06    
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
Aborted
[vsapronenko@localhost ~]$ sudo dnf upgrade
Fedora 25 - x86_64 - VirtualBox                                                                                                                                                                                                                 6.3 kB/s |  33 kB     00:05    
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
Aborted

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/system-python /bin/dnf upgrade
crash_function: load_ext
executable:     /usr/libexec/system-python
global_pid:     12145
kernel:         4.11.5-200.fc25.x86_64
package:        system-python-3.5.3-6.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         system-python killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            0
Comment 17 Kamil Páral 2017-06-21 06:34:09 EDT
Similar problem has been detected:

This happened for the first time when I ran "sudo dnf distro-sync", but it seems to happen for every dnf command ("dnf list installed", "dnf repolist", etc). Esentially I can't do anything with dnf.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/system-python /usr/bin/dnf distro-sync
crash_function: load_ext
executable:     /usr/libexec/system-python
global_pid:     32366
kernel:         4.11.5-200.fc25.x86_64
package:        system-python-3.5.3-6.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         system-python killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            0
Comment 18 Kamil Páral 2017-06-21 06:39:31 EDT
This seems to be the same as bug 1358885. This is likely not a core python crash but dnf or hawkey crash, reassigning.
Comment 19 Kamil Páral 2017-06-21 07:07:13 EDT
There's some problematic package in updates-testing. Dnf crashes after updates-testing metadata is loaded. Look at this:

# rm /var/cache/dnf/* -rf
# dnf repolist --disablerepo='*' --enablerepo=fedora
Fedora 25 - x86_64                                                                    8.1 MB/s |  50 MB     00:06    
Last metadata expiration check: 0:00:17 ago on Wed Jun 21 13:04:48 2017.
repo id                                           repo name                                                     status
*fedora                                           Fedora 25 - x86_64                                            51,669
# dnf repolist --disablerepo='*' --enablerepo=fedora --enablerepo=updates
Fedora 25 - x86_64 - Updates                                                           10 MB/s |  23 MB     00:02    
Last metadata expiration check: 0:00:06 ago on Wed Jun 21 13:05:14 2017.
repo id                                       repo name                                                         status
*fedora                                       Fedora 25 - x86_64                                                51,669
*updates                                      Fedora 25 - x86_64 - Updates                                      20,129
# dnf repolist --disablerepo='*' --enablerepo=fedora --enablerepo=updates --enablerepo=updates-testing
Fedora 25 - x86_64 - Test Updates                                                     5.6 MB/s | 5.1 MB     00:00    
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
Aborted (core dumped)
Comment 20 Kamil Páral 2017-06-21 07:13:40 EDT
We need to identify which package from updates-testing causes this, so that we can unpush it (also make sure it doesn't get pushed stable!). And then we need the bug fixed.
Comment 21 Igor Gnatenko 2017-06-21 07:14:55 EDT
*** Bug 1463505 has been marked as a duplicate of this bug. ***
Comment 22 Igor Gnatenko 2017-06-21 07:14:57 EDT
*** Bug 1463582 has been marked as a duplicate of this bug. ***
Comment 23 Igor Gnatenko 2017-06-21 07:16:12 EDT
*** Bug 1463580 has been marked as a duplicate of this bug. ***
Comment 24 Jacek Pawlyta 2017-06-21 07:24:46 EDT
Kamil,

For me the bug occured today about 9 AM GMT, yesterday aboyt 9 PM GMT everything was OK. Check what was pushed to updates-testing in this particular period of time
Comment 25 Kamil Páral 2017-06-21 07:51:38 EDT
This is also happening on Fedora 24 (with updates-testing) with:
dnf-1.1.10-4.fc24.noarch
hawkey-0.6.4-3.fc24.x86_64
python2-hawkey-0.6.4-3.fc24.x86_64
python3-dnf-1.1.10-4.fc24.noarch
python3-hawkey-0.6.4-3.fc24.x86_64
system-python-3.5.3-6.fc24.x86_64
Comment 26 Kamil Páral 2017-06-21 08:02:26 EDT
Doesn't seem to happen with F26 with:
dnf-2.5.1-1.fc26.noarch
libdnf-0.9.1-1.fc26.x86_64
python3-dnf-2.5.1-1.fc26.noarch
python3-hawkey-0.9.1-1.fc26.x86_64
system-python-3.6.1-6.fc26.x86_64

Probably either because dnf 2 fixes this, or because the offending package is not in F26 updates-testing repo.
Comment 27 Jiří Vymazal 2017-06-21 08:06:15 EDT
As far as I know dnf 2 does not include hawkey and rather uses libdnf
Comment 28 Igor Gnatenko 2017-06-21 08:07:16 EDT
It is irrelevant here..
Comment 29 Igor Gnatenko 2017-06-21 08:11:01 EDT
https://dl.fedoraproject.org/pub/fedora/linux/updates/testing/25/x86_64/repodata/

Contains 2 *-updateinfo.xml.xz... and one is referenced from repomd.xml is actually sqlite DB...


So something fucked up mashing or something like that..



Not a bug in DNF.
Comment 30 Igor Gnatenko 2017-06-21 08:19:25 EDT
*** Bug 1463645 has been marked as a duplicate of this bug. ***
Comment 31 Alexander Ploumistos 2017-06-21 08:26:25 EDT
Has anyone notified infrastructure?
Comment 32 Joachim Frieben 2017-06-21 09:25:27 EDT
I have spotted this issue today for the first time when running 'dnf install ..' after having installed the latest packages from "updates-testing" via gnome-software. Yesterday, 'dnf' was still working correctly.
Comment 33 Kamil Páral 2017-06-21 09:32:43 EDT
We have identified the issue and Infra is working on fixing the repos. Everybody please just wait, it should be fixed in a day or less.
Comment 34 Miloslav Trmač 2017-06-21 09:33:17 EDT
(In reply to Igor Gnatenko from comment #29)
> Contains 2 *-updateinfo.xml.xz... and one is referenced from repomd.xml is
> actually sqlite DB...
<snip>
> Not a bug in DNF.

It would still be very nice if whatever is crashing instead handled the error and reported something actionable, like “parsing file downloaded from $URL failed”.
Comment 35 Colin Walters 2017-06-21 09:53:46 EDT
@mtrmac: Newer libdnf already does set an error properly in this case, it's only f25's dnf that has this problem.
Comment 36 Miro Hrončok 2017-06-21 10:29:54 EDT
*** Bug 1463689 has been marked as a duplicate of this bug. ***
Comment 37 Nadav Goldin 2017-06-21 10:34:57 EDT
Hitting this too, thanks for looking into this quickly. Are there any suggested workarounds at the moment?
Comment 38 Kevin L. Mitchell 2017-06-21 10:55:33 EDT
Encountering this on Fedora 25, updated yesterday, and note that I *DO NOT* have updates-testing enabled.
Comment 39 Kamil Páral 2017-06-21 11:06:55 EDT
Yes, it seems to affect all repos, not just updates-testing. It depends how up-to-date your mirror is. Please wait. You might be able to use packagekit/gnome-software to install packages as a workaround (not tested).
Comment 40 Garry T. Williams 2017-06-21 11:28:03 EDT
(In reply to Kamil Páral from comment #20)
> We need to identify which package from updates-testing causes this, so that
> we can unpush it (also make sure it doesn't get pushed stable!). And then we
> need the bug fixed.

Too late:

$ sudo dnf repolist --disablerepo='*' --enablerepo=fedora
[sudo] password for garry: 
Fedora 25 - x86_64                              1.2 MB/s |  50 MB     00:43    A
Last metadata expiration check: 0:00:41 ago on Wed Jun 21 11:25:23 2017.
repo id                        repo name                                  status
*fedora                        Fedora 25 - x86_64                         51,669
$ sudo dnf repolist --disablerepo='*' --enablerepo=fedora --enablerepo=updates
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
zsh: abort      sudo dnf repolist --disablerepo='*' --enablerepo=fedora --enablerepo=updates
$
Comment 41 Reymer Antonio Vargas Solano 2017-06-21 11:37:59 EDT
(In reply to Kamil Páral from comment #33)
> We have identified the issue and Infra is working on fixing the repos.
> Everybody please just wait, it should be fixed in a day or less.

Thanks for your support!
Comment 42 Donald O. 2017-06-21 11:39:16 EDT
since today got that too:
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.

I did:
rm -f /var/lib/rpm/__db*
rpm --rebuilddb
dnf clean al

and everything works fine again.
Comment 43 Kevin L. Mitchell 2017-06-21 11:50:38 EDT
(In reply to Donald O. from comment #42)
> since today got that too:
> system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext:
> Assertion `ret == 0' failed.
> 
> I did:
> rm -f /var/lib/rpm/__db*
> rpm --rebuilddb
> dnf clean al
> 
> and everything works fine again.

It *looks like* it works, because it starts downloading repos, but once it actually goes into the phase where it computes the list of updates, it cores again for me.
Comment 44 Augusto Caringi 2017-06-21 11:51:38 EDT
Just to let you know:

In my F25 there are 2 repos causing the problem: updates-testing and updates.

If I disable both, dnf works...
Comment 45 Thom Carlin 2017-06-21 11:57:17 EDT
In one case, dnf clean all worked

For another, From https://bugzilla.redhat.com/show_bug.cgi?id=1463561#c44, I removed contents of /var/cache/yum/x86_64/25/updates and it started working for me.
Comment 46 luc.vanrobays 2017-06-21 11:58:54 EDT
I also did 

rm -f /var/lib/rpm/__db*
rpm --rebuilddb
dnf clean all


works ok except when reaching repo

Fedora 25 - x86_64 - Updates

Disabling Fedora 25 - x86_64 - Updates

dnf works..
Comment 47 Chuck McAndrew 2017-06-21 12:01:49 EDT
I am on Fedora 24 still. Have the same issue. Updates-Testing is not enabled. Disabling Fedora-Updates allows dnf to complete.
Comment 48 Ronald Hudson 2017-06-21 12:07:41 EDT
Found my solution at:
http://forums.fedoraforum.org/showthread.php?p=1789198

-------
This worked for me ... (although on a second machine I had to do it twice ,,,)

# dnf clean all
# dnf --disablerepo=updates update
# dnf update


-----
After above my dnf no longer gives the described error message.

If this is any help:
$ uname -a
Linux pilot.local 4.11.5-200.fc25.x86_64 #1 SMP Wed Jun 14 17:17:29 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Comment 49 Ronald Hudson 2017-06-21 12:08:49 EDT
Found my solution at:
http://forums.fedoraforum.org/showthread.php?p=1789198

-------
This worked for me ... (although on a second machine I had to do it twice ,,,)

# dnf clean all
# dnf --disablerepo=updates update
# dnf update


-----
After above my dnf no longer gives the described error message.

If this is any help:
$ uname -a
Linux pilot.local 4.11.5-200.fc25.x86_64 #1 SMP Wed Jun 14 17:17:29 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Comment 50 Kevin Fenzi 2017-06-21 12:13:39 EDT
The master mirrors have been fixed, and mirrormanager has been told to not hand out the previous (bad) checksum. 

So, dnf --refresh or dnf clean all should get everyone working now provided you are using the (default) metalink. Other mirrors should sync up over today.
Comment 51 Chuck McAndrew 2017-06-21 12:16:47 EDT
Confirmed that fixed it for me.
Comment 52 Athos Ribeiro 2017-06-21 12:19:48 EDT
Thank you for the quick response on this! It seems to be fixed now
Comment 53 Igor Gnatenko 2017-06-21 12:21:33 EDT
Thanks a lot to Patrick Uiterwijk for quickfixing it and everyone who was involved ;)
Comment 54 Kevin Fenzi 2017-06-21 12:25:34 EDT
*** Bug 1463751 has been marked as a duplicate of this bug. ***
Comment 55 Randy Barlow 2017-06-21 12:55:56 EDT
This Bodhi issue has been filed about removing the code that caused this problem, and it references a PR that will fix it:

https://github.com/fedora-infra/bodhi/issues/1634
Comment 56 Donald O. 2017-06-21 16:13:52 EDT
got resonse from other users who also can fix the problem by my recipe. Therefore I conclude the problem is related to the well-known https://fedoramagazine.org/psa-errors-updating-libdb/
Comment 57 Michal Jaegermann 2017-06-21 17:34:06 EDT
(In reply to Donald O. from comment #56)
> got resonse from other users who also can fix the problem by my recipe.

A success of your recipe depends on dnf getting either "sane" data for updates repo or none at all.  As fixed repos are propagating through mirrors chances are that you will end up OK.

OTOH if you had dnf-makecache.timer active then every time it fired with "bad" repos dnf was dumping a core and this was quite quickly accumulating in /var/lib/systemd/coredump/.  It is a good idea to check what it sitting there.
Comment 58 Vitaliy Sapronenko 2017-06-22 05:50:08 EDT
Similar problem has been detected:


reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/system-python /usr/bin/dnf info flash-player
crash_function: load_ext
executable:     /usr/libexec/system-python
global_pid:     4107
kernel:         4.11.5-200.fc25.x86_64
package:        system-python-3.5.3-6.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         system-python killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 59 Igor Gnatenko 2017-06-23 04:07:05 EDT
*** Bug 1464344 has been marked as a duplicate of this bug. ***
Comment 60 Vitaliy Sapronenko 2017-06-26 04:53:16 EDT
Similar problem has been detected:


reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/system-python /usr/bin/dnf info flash-plugin
crash_function: load_ext
executable:     /usr/libexec/system-python
global_pid:     25016
kernel:         4.11.6-200.fc25.x86_64
package:        system-python-3.5.3-6.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         system-python killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 61 Dan Loomis 2017-06-28 22:36:52 EDT
Similar problem has been detected:

Didn't know the problem had occurred.   Found it in the problem reporting tool

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/system-python /usr/bin/dnf makecache timer
crash_function: load_ext
executable:     /usr/libexec/system-python
global_pid:     8077
kernel:         4.11.5-200.fc25.x86_64
package:        system-python-3.5.3-6.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         system-python killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            0
Comment 62 selwyntcy 2017-07-13 03:25:40 EDT
It seems to be fixed by Bug 1451212 - epel.repo: mirrorlist instead of metalink https://bugzilla.redhat.com/show_bug.cgi?id=1451212.

The corresponding epel release epel-release-7-10.noarch does fix my same issue.

Note You need to log in before you can comment on or make changes to this bug.