Bug 1463800 - qpidd consuming huge memory during scale
qpidd consuming huge memory during scale
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Qpid (Show other bugs)
6.2.9
Unspecified Unspecified
urgent Severity urgent (vote)
: GA
: --
Assigned To: Mike Cressman
jcallaha
scale_lab
: FieldEngineering, Performance, PrioBumpField, PrioBumpPM, Reopened, Triaged
Depends On: 1450948 1468450
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 15:34 EDT by pm-sat@redhat.com
Modified: 2018-06-01 10:23 EDT (History)
39 users (show)

See Also:
Fixed In Version: qpid-cpp-1.36.0-7
Doc Type: Bug Fix
Doc Text:
During scaling testing of content hosts, qpid consumed huge amounts of memory. This is now fixed.
Story Points: ---
Clone Of: 1367735
Environment:
Last Closed: 2018-02-21 07:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-7677 None None None 2017-06-21 15:35 EDT
Red Hat Knowledge Base (Solution) 2720301 None None None 2017-06-21 15:35 EDT
Red Hat Knowledge Base (Solution) 3065531 None None None 2017-06-21 15:35 EDT
Red Hat Product Errata RHBA-2018:0338 normal SHIPPED_LIVE Red Hat Satellite 6.3 Tools 2018-02-21 14:30:02 EST

  None (edit)
Comment 6 jcallaha 2018-02-07 10:47:08 EST
Verified in Satellite 6.3 Snap 31/35.

The tested behavior, in Snap 31, shows an increase of approximately 1MB qpid memory consumption per additional host running katello-agent. Scaling up to 10k hosts, running katello-agent, qpid showed a memory consumption around 10G. This is a 60% drop from the consumption in the initial report!

Additionally, none of our automated or manual tests have shown any breakage from incorporating the new qpid version.
Comment 9 errata-xmlrpc 2018-02-21 07:57:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0338

Note You need to log in before you can comment on or make changes to this bug.