This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 146387 - Ruby-libs is packaged incorrectly, files missing.
Ruby-libs is packaged incorrectly, files missing.
Status: CLOSED DUPLICATE of bug 146055
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
: 146497 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 14:50 EST by Rene Rask
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rene Rask 2005-01-27 14:50:18 EST
Description of problem:
Ruby-libs is missing files. The ruby.spec file has a script for
sorting files into libs which is broken. Some files end up in
ruby-libs and some end up in ruby-tcltk. rexml/namespace.rb is one of
them.
The problems is only apparent if ruby-tcltk is not installed. 

Version-Release number of selected component (if applicable):
ruby-1.8.2-1.FC3.0
ruby-libs-1.8.2-1.FC3.0

How reproducible:
every time

Steps to Reproduce:
1. Do not install ruby-tcltk or remove it if already installed.
2. Use an application that uses rexml.
3.
  
Actual results:
Application using rexml breaks in misson required files.

Expected results:
Application should work.

Additional info:
I tested this with ruby-glade-create-template from the ruby-gnome2
project.
The workaround is of course to install ruby-tcltk even though you
don't want to use tcltk.
Other problems may be caused by this, but this was the one that hit me.
Comment 1 Akira TAGOH 2005-01-27 21:33:20 EST

*** This bug has been marked as a duplicate of 146055 ***
Comment 2 Ariel Segall 2005-01-28 16:09:32 EST
*** Bug 146497 has been marked as a duplicate of this bug. ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:08:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.