Bug 1463906 - [abrt] dnfdragora: __call__(): __init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object
Summary: [abrt] dnfdragora: __call__(): __init__.py:187:__call__:RecursionError: maxim...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:262ebebddb185f587828b18971b...
: 1542704 1562658 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-22 05:36 UTC by Delete My Account
Modified: 2018-09-23 11:26 UTC (History)
14 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:27:01 UTC


Attachments (Terms of Use)
File: backtrace (676 bytes, text/plain)
2017-06-22 05:37 UTC, Delete My Account
no flags Details
File: cgroup (289 bytes, text/plain)
2017-06-22 05:37 UTC, Delete My Account
no flags Details
File: cpuinfo (1.32 KB, text/plain)
2017-06-22 05:37 UTC, Delete My Account
no flags Details
File: environ (1.36 KB, text/plain)
2017-06-22 05:37 UTC, Delete My Account
no flags Details
File: mountinfo (3.39 KB, text/plain)
2017-06-22 05:37 UTC, Delete My Account
no flags Details
File: namespaces (102 bytes, text/plain)
2017-06-22 05:37 UTC, Delete My Account
no flags Details
File: open_fds (927 bytes, text/plain)
2017-06-22 05:37 UTC, Delete My Account
no flags Details

Description Delete My Account 2017-06-22 05:36:59 UTC
Description of problem:
CPU is overworking during updates

Version-Release number of selected component:
dnfdragora-1.0.1-5.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora
crash_function: __call__
exception_type: RecursionError
executable:     /usr/bin/dnfdragora
kernel:         4.12.0-0.rc5.git2.1.fc27.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
__init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 187, in __call__
    return getattr(self.proxy, self.method)(*args)
RecursionError: maximum recursion depth exceeded while calling a Python object

Local variables in innermost frame:
args: (<Gio.DBusProxy object at 0x7f796c2edb88 (GDBusProxy at 0x5589f8a4b650)>, ':1.63', 'RPMProgress', GLib.Variant('(ssiiii)', ('glibc-langpack-en,0,2.25.90,7.fc27,x86_64,rawhide', 'verify', 100, 100, 40, 102)))
self: <dnfdaemon.client.WeakMethod object at 0x7f796c2df320>

Potential duplicate: bug 1452600

Comment 1 Delete My Account 2017-06-22 05:37:07 UTC
Created attachment 1290488 [details]
File: backtrace

Comment 2 Delete My Account 2017-06-22 05:37:09 UTC
Created attachment 1290489 [details]
File: cgroup

Comment 3 Delete My Account 2017-06-22 05:37:11 UTC
Created attachment 1290490 [details]
File: cpuinfo

Comment 4 Delete My Account 2017-06-22 05:37:13 UTC
Created attachment 1290491 [details]
File: environ

Comment 5 Delete My Account 2017-06-22 05:37:16 UTC
Created attachment 1290492 [details]
File: mountinfo

Comment 6 Delete My Account 2017-06-22 05:37:18 UTC
Created attachment 1290493 [details]
File: namespaces

Comment 7 Delete My Account 2017-06-22 05:37:20 UTC
Created attachment 1290494 [details]
File: open_fds

Comment 8 Jan Kurik 2017-08-15 06:15:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 9 Joshua Malone 2017-10-23 04:37:40 UTC
*** Bug 1505223 has been marked as a duplicate of this bug. ***

Comment 10 Morgan 2017-10-23 12:06:00 UTC
*** Bug 1505360 has been marked as a duplicate of this bug. ***

Comment 11 Herbert Carl Meyer 2017-10-28 15:07:08 UTC
Similar problem has been detected:

Running update

reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: __call__
exception_type: RecursionError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.9-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object
runlevel:       N 5
type:           Python3
uid:            1000

Comment 12 clz71079 2017-11-22 00:46:31 UTC
Similar problem has been detected:

Two programs were correctly installed, but dnfdragora crashed afterward.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora
crash_function: __call__
exception_type: RecursionError
executable:     /usr/bin/dnfdragora
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object
runlevel:       N 5
type:           Python3
uid:            1002

Comment 13 Eugene Mah 2017-12-06 14:51:53 UTC
Similar problem has been detected:

Selected a package to install. dnfdragora crashed when I clicked the Apply button

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora
crash_function: __call__
exception_type: RecursionError
executable:     /usr/bin/dnfdragora
kernel:         4.13.16-302.fc27.x86_64
package:        dnfdragora-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object
runlevel:       N 5
type:           Python3
uid:            1000

Comment 14 Fedora Update System 2017-12-29 23:20:58 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 15 Fedora Update System 2017-12-29 23:26:36 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 16 Fedora Update System 2017-12-30 19:53:28 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 17 Fedora Update System 2017-12-30 20:39:15 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 18 Eduardo Medina 2017-12-30 23:12:15 UTC
*** Bug 1529895 has been marked as a duplicate of this bug. ***

Comment 19 Fedora Update System 2017-12-31 21:27:01 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-01-01 22:10:40 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 ricky.tigg 2018-01-10 07:51:24 UTC
Similar problem has been detected:

After all available updates were downloaded application begins the installation update process. No other application were opened during that process or were already running when application was launched.

reporter:       libreport-2.9.3
cmdline:        python3 /usr/bin/dnfdragora
crash_function: __call__
exception_type: RecursionError
executable:     /usr/bin/dnfdragora
kernel:         4.14.11-300.fc27.x86_64
package:        dnfdragora-1.0.1-8.git20171229.24e4647.fc27
reason:         __init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object
runlevel:       N 5
type:           Python3
uid:            1000

Comment 22 ricky.tigg 2018-02-06 21:01:52 UTC
*** Bug 1542704 has been marked as a duplicate of this bug. ***

Comment 23 lewalberts 2018-04-02 02:20:02 UTC
*** Bug 1562658 has been marked as a duplicate of this bug. ***

Comment 24 Alex. H. F. 2018-09-23 11:26:42 UTC
Similar problem has been detected:

Laptop went into sleep-mode, possibly still during dnf update...
After waking computer up from sleep, packagekit was using 100% of CPU.
Killed packagekit to be able to restart system. Did so.
On system-restart, started dnnfdrgora to check if everything done.
2 pacakges were still available.
Started update of these remaining packages.
dnfdragora crahsed with this message...

reporter:       libreport-2.9.3
cmdline:        python3 /usr/bin/dnfdragora
crash_function: __call__
exception_type: RecursionError
executable:     /usr/bin/dnfdragora
kernel:         4.18.7-100.fc27.x86_64
package:        dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27
reason:         __init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object
runlevel:       N 5
type:           Python3
uid:            1000


Note You need to log in before you can comment on or make changes to this bug.