Bug 1463960 - anaconda fails to start during installation with ModuleNotFoundError: No module named 'pyanaconda.threads'
anaconda fails to start during installation with ModuleNotFoundError: No modu...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 03:10 EDT by Sinny Kumari
Modified: 2017-10-03 12:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-27.15-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-23 05:11:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sinny Kumari 2017-06-22 03:10:28 EDT
Description of problem:
While trying to install a latest rawhide ISO image, anaconda fails to start with 
error message ModuleNotFoundError: No module named 'pyanaconda.threads'
$ anaconda
Starting installer, one moment...
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 282, in <module>
    from pyanaconda import startup_utils
  File "/usr/lib64/python3.6/site-packages/pyanaconda/startup_utils.py", line 40, in <module>
    from pyanaconda import kickstart
  File "/usr/lib64/python3.6/site-packages/pyanaconda/kickstart.py", line 22, in <module>
    from pyanaconda.threads import threadMgr
ModuleNotFoundError: No module named 'pyanaconda.threads'


Version-Release number of selected component (if applicable): anaconda-27.14-1.fc27

How reproducible:
* Garb a latest rawhide iso image e.g. https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20170621.n.0/compose/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-Rawhide-20170621.n.0.iso
* Boot the iso and start anaconda installation
* Fails while loading anaconda

Noticed this behavior on both x86_64 and ppc64(le). Haven't checked other arches.
Comment 1 Martin Kolman 2017-06-22 07:42:39 EDT
This should be fixed once anaconda-27.15-1 hits the composes.
Comment 2 Sinny Kumari 2017-06-23 05:11:21 EDT
Rawhide nightly compose from 20170622.n.0 seems to have anaconda-27.15-1 . Anaconda installer starts perfectly and was able to install successfully iso from 20170622.n.0 .
Comment 3 Scott Dowdle 2017-10-03 12:00:29 EDT
I'm getting this same issue on recent Fedora 26 rebuilds with anaconda-26.21.12-1.fc26.x86_64
Comment 4 Scott Dowdle 2017-10-03 12:03:22 EDT
On Fedora 26 it looks like the trouble package update was for python3-blivet-2.1.11-1.fc26.noarch which gives the following error when trying to run liveinst:

Traceback (most recent call last):
  File "/sbin/anaconda", line 577, in <module>
    blivet.enable_installer_mode()
  File "/usr/lib/python3.6/site-packages/blivet/__init__.py", line 127, in enable_installer_mode
    from pyanaconda.anaconda_logging import program_log_lock
ModuleNotFoundError: No module named 'pyanaconda.anaconda_logging'
Comment 5 Scott Dowdle 2017-10-03 12:09:53 EDT
Downgrading python3-blivet on my troubled livemedia fixes it.
Comment 6 Scott Dowdle 2017-10-03 12:32:05 EDT
Nevermind, I see this new bug report (https://bugzilla.redhat.com/show_bug.cgi?id=1497677) and they already have an updated package in updates-testing.

Note You need to log in before you can comment on or make changes to this bug.