This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1464199 - drop m2crypto requirements on ovirt-host-deploy execution
drop m2crypto requirements on ovirt-host-deploy execution
Status: ON_QA
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.VDSM (Show other bugs)
master
Unspecified Unspecified
high Severity medium (vote)
: ovirt-4.2.0
: 1.7.0
Assigned To: Yedidyah Bar David
Pavol Brilla
:
Depends On:
Blocks: 1471196
  Show dependency treegraph
 
Reported: 2017-06-22 11:52 EDT by Sandro Bonazzola
Modified: 2017-09-28 04:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78539 master MERGED ovirt-release-master: add m2crypto back on node 2017-06-22 12:00 EDT
oVirt gerrit 81390 master POST plugins: vdsm: Remove all references to m2crypto 2017-09-04 03:05 EDT

  None (edit)
Description Sandro Bonazzola 2017-06-22 11:52:18 EDT
vdsm dropped dependency on m2crypto in https://gerrit.ovirt.org/76027 without removing its runtime requirement for certificate enrollment in ovirt-host-deploy.
Result is that ovirt-node can't be added anymore as hypervisor since m2crypto is not installed anymore on ovirt-node not being required by vdsm and fails running certificate enrollment.

As temporary solution we're forcing m2crypto installation on ovirt-node but since we are abandoning m2crypto in other projects we should go ahead and remove here as well.
Comment 1 Sandro Bonazzola 2017-09-04 01:59:46 EDT
Didi, can you please check if solution for bug #1471196 solved this one as well?
Comment 2 Yedidyah Bar David 2017-09-04 02:54:47 EDT
(In reply to Sandro Bonazzola from comment #1)
> Didi, can you please check if solution for bug #1471196 solved this one as
> well?

Almost.

We still have there code to install m2crypto, and code to use it, but the code to use is disabled by the patch to bug #1471196.

As discussed in private, it doesn't seem like we'll return to m2crypto for host-deploy, so I'd rather remove all code. We can always copy from git history if needed.

Note You need to log in before you can comment on or make changes to this bug.