Bug 146439 - gimp 2.2.2 crash at startup - segmantation fault
gimp 2.2.2 crash at startup - segmantation fault
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
: 146642 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-28 03:53 EST by Nicu Buculei
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 08:54:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicu Buculei 2005-01-28 03:53:00 EST
Description of problem:
updated Gimp from default version in FC3 to the latest in updates and
it crashes at startup with 'segmantation fault' error

Version-Release number of selected component (if applicable):
gimp-2.2.2-0.fc3.3


Actual results:

[nicu@nicu ~]$ gimp

(gimp:4775): GLib-GObject-WARNING **: specified class size for type
`GimpContainerEntry' is smaller than the parent type's `GtkEntry'
class size

(gimp:4775): GLib-GObject-CRITICAL **: file gtype.c: line 2319
(g_type_add_interface_static): assertion `G_TYPE_IS_INSTANTIATABLE
(instance_type)' failed

(gimp:4775): GLib-GObject-CRITICAL **: file gobject.c: line 819
(g_object_new): assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gimp:4775): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
535 (gimp_container_view_set_preview_size): assertion
`GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp:4775): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
306 (gimp_container_view_set_container): assertion
`GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp:4775): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
450 (gimp_container_view_set_context): assertion
`GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp:4775): Gtk-CRITICAL **: file gtkwidget.c: line 5592
(gtk_widget_set_size_request): assertion `GTK_IS_WIDGET (widget)' failed

(gimp:4775): Gtk-CRITICAL **: file gtkbox.c: line 373
(gtk_box_pack_start): assertion `GTK_IS_WIDGET (child)' failed
Segmentation fault
Comment 1 Nils Philippsen 2005-01-28 03:57:45 EST
Which version of gtk2 do you have? I have:

nils@wombat:~> rpm -q gimp gtk2
gimp-2.2.2-0.fc3.3
gtk2-2.4.14-2.fc3

and it works beautifully here. This kind of error hints of that you
have mixed up Rawhide and FC3 packages somehow.
Comment 2 Nicu Buculei 2005-01-28 04:07:39 EST
thanks for the tip, it appears gtk2 was too old (gtk2-2.4.13-9), which
is surprising, because i used yum to update gimp and expected all
dependencies (like gtk2) to be upgraded as needed.
however, after manually updating gtk2 it appears to work, thanks
Comment 3 Nils Philippsen 2005-01-28 05:08:32 EST
The problem in this case was that GIMP was built against an updated
version of gtk2 which apparently is not backwards compatible in the
way that binaries built with the newer version of gtk2 won't 100% run
against the older version. This is not a problem of yum -- it can't
know that the new gimp needs the new gtk2, even the gimp package
itself can't know it. Reassigning this to gtk2.
Comment 4 Matthias Clasen 2005-01-28 08:51:50 EST
gtk2 has never guaranteed this form of backwards compatibility. If you
want something to run against gtk 2.x you have to build it against 2.x.
Comment 8 Matthias Clasen 2005-01-28 09:44:56 EST
Sorry, I should have read the bug more carefully.

In this case, it is an ABI break, as acknowledged in the 
rpm changelog:

* Wed Dec 01 2004 Matthias Clasen <mclasen@redhat.com> - 2.4.13-10.fc3
- Fix an inadverted ABI break which crept in
  with the backspace patch.  (#151450)

Sorry about that.
Comment 9 Nils Philippsen 2005-01-28 10:30:03 EST
Does this mean that we will have to rebuild against 2.4.13-10.fc3?
Comment 10 Matthias Clasen 2005-01-28 10:33:58 EST
Rebuilding against 2.4.14-2.fc3 should work fine
Comment 11 Nils Philippsen 2005-01-28 11:23:59 EST
So the ABI breakage was in 2.4.13-9 and not 2.4.14-2.fc3? Now I
understand ;-).
Comment 12 Nils Philippsen 2005-02-01 10:11:41 EST
*** Bug 146642 has been marked as a duplicate of this bug. ***
Comment 13 Nicu Buculei 2005-02-04 02:07:10 EST
it appears upgrading the gtk2 package also solved a crash in Inkscape
(from Fedora Extras) occuring when opening the 'XML Editor'

Note You need to log in before you can comment on or make changes to this bug.