Bug 146642 - Red hat initialization error
Red hat initialization error
Status: CLOSED DUPLICATE of bug 146439
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-31 09:06 EST by Robert Perez
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 10:11:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Perez 2005-01-31 09:06:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Whem I initialize the gimp 2.2 program, 
the system show the gimp splash screen during a few seconds.
Later, the system hides the splash screen and the gimp main window is
not showed (and I no have a gimp process).

If I execute gimp from the command line, a error is reportered...

Thank's


[robert@matrix Html]$ gimp

(gimp:6478): GLib-GObject-WARNING **: specified class size for type
`GimpContainerEntry' is smaller than the parent type's `GtkEntry'
class size

(gimp:6478): GLib-GObject-CRITICAL **: file gtype.c: line 2319
(g_type_add_interface_static): assertion `G_TYPE_IS_INSTANTIATABLE
(instance_type)' failed

(gimp:6478): GLib-GObject-CRITICAL **: file gobject.c: line 819
(g_object_new): assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gimp:6478): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
535 (gimp_container_view_set_preview_size): assertion
`GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp:6478): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
306 (gimp_container_view_set_container): assertion
`GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp:6478): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line
450 (gimp_container_view_set_context): assertion
`GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp:6478): Gtk-CRITICAL **: file gtkwidget.c: line 5592
(gtk_widget_set_size_request): assertion `GTK_IS_WIDGET (widget)' failed

(gimp:6478): Gtk-CRITICAL **: file gtkbox.c: line 373
(gtk_box_pack_start): assertion `GTK_IS_WIDGET (child)' failed
Violaci�n de segmento


Version-Release number of selected component (if applicable):
gimp-2.2.2-0.fc3.3

How reproducible:
Always

Steps to Reproduce:
1. execute gimp
2.
3.
    

Actual Results:  the gimp product don't works...

Expected Results:  the gimp product works fine...

Additional info:
Comment 1 Nils Philippsen 2005-02-01 03:23:03 EST
It is most likely that you need to update your gtk2 packages. I have
gtk2-2.4.14-2.fc3, gimp-2.2.3-0.fc3.2 and everything works OK, which version of
gtk2 do you have?
Comment 2 Robert Perez 2005-02-01 05:47:42 EST
Hello, 
I have installed the gtk-2.4.14-2.fc3 update and gimp works fine now...
Thank's!!!
Comment 3 Nils Philippsen 2005-02-01 10:11:39 EST

*** This bug has been marked as a duplicate of 146439 ***

Note You need to log in before you can comment on or make changes to this bug.