Bug 1464397 - Webhook urls in BC edit page are invalid with "undefined" included
Webhook urls in BC edit page are invalid with "undefined" included
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jessica Forrester
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 06:53 EDT by Xingxing Xia
Modified: 2017-08-16 15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:28:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
invalid-webhook-urls (58.32 KB, image/png)
2017-06-23 06:59 EDT, Xingxing Xia
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1716 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.6 RPM Release Advisory 2017-08-10 05:02:50 EDT

  None (edit)
Description Xingxing Xia 2017-06-23 06:53:01 EDT
Description of problem:
Webhook urls in BC edit page are invalid with "undefined" included

Version-Release number of selected component (if applicable):
OCP v3.6.122

How reproducible:
Always

Steps to Reproduce:
1. $ oc new-app centos/ruby-22-centos7~https://github.com/openshift/ruby-ex.git # Create BC
2. On BC ruby-ex page, click Actions --> Edit --> Show advanced options. In "Triggers" part, check the webhook urls
3. Add webhook (any type), check the webhook url in text box

Actual results:
2 and 3:
The webhook urls look like:
https://...:8443/oapi/v1/namespaces/xxia-test/buildconfigs/ruby-ex/webhooks/undefined/github

Click "Click to clipboard", paste, the pasted url also includes "undefined"

Check BC Configuration tab, the webhook urls are valid like:
https://...:8443/oapi/v1/namespaces/xxia-test/buildconfigs/ruby-ex/webhooks/uaI8TxDyq0WhJwd20JIH/github

Expected results:
2 and 3:
Should be valid urls, like in BC Configuration tab


Additional info:
Comment 1 Xingxing Xia 2017-06-23 06:59 EDT
Created attachment 1290976 [details]
invalid-webhook-urls
Comment 2 openshift-github-bot 2017-06-23 12:41:12 EDT
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/b27c9acdf6ab5003cc57121722faddc74dc4b503
Bug 1464397 and Bug 1461702 - problems with webhook trigger urls and display
Comment 3 Jessica Forrester 2017-06-23 12:42:28 EDT
Fixed in https://github.com/openshift/origin-web-console/pull/1763
Comment 5 shahan 2017-06-28 23:31:46 EDT
Tested this issue in openshift v3.6.126.1, the webhooks url is valid without "undefined".
Comment 7 errata-xmlrpc 2017-08-10 01:28:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.