Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1464484 - RFE: backport SELinux/InfiniBand policy [NEEDINFO]
RFE: backport SELinux/InfiniBand policy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.5
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
Mirek Jahoda
: FutureFeature
Depends On: 1464478 1464489 1466274 1466276 1523309
Blocks: 1449326
  Show dependency treegraph
 
Reported: 2017-06-23 10:15 EDT by Paul Moore
Modified: 2018-04-10 08:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-174.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 08:32:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pmoore: needinfo? (lvrabec)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0763 None None None 2018-04-10 08:33 EDT

  None (edit)
Description Paul Moore 2017-06-23 10:15:56 EDT
Description of problem:
Backport the SELinux policy to enable the InfiniBand access controls.  See BZ #1449326 for the RHEL-7.x customer request.

Additional info:

Additional patches may also be necessary, but at a minimum the backport should include the upstream commit below:

  commit 25a5b2427447eb14edb07ce302217d37528813bc
  Author: Daniel Jurgens <danielj@mellanox.com>
  Date:   Wed May 24 17:14:59 2017 +0300

    refpolicy: Infiniband pkeys and endports
    
    Every Infiniband network will have a default pkey, so that is labeled.
    The rest of the pkey configuration is network specific. The policy allows
    access to the default and unlabeled pkeys for sysadm and staff users.
    kernel_t is allowed access to all pkeys, which it needs to process and
    route management datagrams.
    
    Endports are all unlabeled by default, sysadm users are allowed to
    manage the subnet on unlabeled endports. kernel_t is allowed to manage
    the subnet on all ibendports, which is required for configuring the HCA.
    
    This patch requires selinux series: "SELinux user space support for
    Infiniband RDMA", due to the new ipkeycon labeling mechanism.
    
    Signed-off-by: Daniel Jurgens <danielj@mellanox.com>
Comment 3 Paul Moore 2017-10-12 12:48:44 EDT
Lukas, just a quick mention that I had to add the following policy rules to the selinux-testsuite policy (see https://bugzilla.redhat.com/show_bug.cgi?id=1464478#c9), is there something that should be added in the RHEL-7.x base policy?

--- a/policy/test_ibpkey.te
+++ b/policy/test_ibpkey.te
@@ -28,3 +28,8 @@ corenet_ib_access_unlabeled_pkeys(test_ibpkey_access_t)
 # Allow all of these domains to be entered from the sysadm domain.
 miscfiles_domain_entry_test_files(ibpkeydomain)
 userdom_sysadm_entry_spec_domtrans_to(ibpkeydomain)
+
+# XXX - need for test to pass
+allow test_ibpkey_access_t proc_net_t:file { open read getattr };
+allow test_ibpkey_access_t self:capability { ipc_lock };
+
Comment 8 errata-xmlrpc 2018-04-10 08:32:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0763

Note You need to log in before you can comment on or make changes to this bug.