Bug 1464487 - Use gtkspell3 for BuildRequires instead of orphaned gtkspell
Use gtkspell3 for BuildRequires instead of orphaned gtkspell
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1465835
  Show dependency treegraph
 
Reported: 2017-06-23 10:18 EDT by Jan Pokorný
Modified: 2017-06-28 06:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1465835 (view as bug list)
Environment:
Last Closed: 2017-06-26 09:57:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2017-06-23 10:18:29 EDT
Trigger for this request:
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/JVLNDQVT37W3GGQ5IADLHVZNYOLZ524Q/
(look for gtkspell and you'll find that inkscape is affected)

Indeed, gtkspell is orphaned now:
https://admin.fedoraproject.org/pkgdb/package/rpms/gtkspell/

So encouraged by inkscape build system sources, I tried simply:

diff --git a/inkscape.spec b/inkscape.spec
index 5d35c7d..b0d5aa7 100644
--- a/inkscape.spec
+++ b/inkscape.spec
@@ -26,7 +26,7 @@ BuildRequires:  gc-devel >= 6.4
 BuildRequires:  gettext
 BuildRequires:  gsl-devel
 BuildRequires:  gtkmm30-devel
-BuildRequires:  gtkspell-devel
+BuildRequires:  gtkspell3-devel
 BuildRequires:  ImageMagick-c++-devel
 BuildRequires:  intltool
 BuildRequires:  lcms2-devel

And it worked well as far as building and grabing automatic so-based
Requires.

Then I tried to check the function of the spell checker from within
inkscape built like that:

1. select "Create and edit text objects (F8)"
2. enter some random text
3. go to main menu > Text > Check spelling
4. observe new embedded dialog just with one button active
   -- "Stop"
5. if you click on that button, you'll get a segfault

But after reinstalling inkscape with original Fedora version using
gtkspell, I got the same behavior, so I don't really think this would
be a regression -- it's rather a pre-existing bug that should not
block getting rid of dependency on now-orphaned package.
Comment 1 Jan Pokorný 2017-06-23 10:22:07 EDT
Note when I run inkscape from terminal, I can observe

> ** (inkscape:20386): WARNING **: Error: No word lists can be found for the language "en_US".

prior to the crash.

Also regarding the BuildRequires change accepted by the build system:

> -- Checking for module 'gtkspell3-3.0'
> --   Found gtkspell3-3.0, version 3.0.9
> [...]
> ------------------------------
> Building Makefile for Inkscape
> ------------------------------
> [...]
> Using GtkSpell 3

So it seems accepted just fine.
Comment 2 Gwyn Ciesla 2017-06-23 13:50:44 EDT
Committed, but the build failed due to rawhide breakage.  I'll try again in a day or so.

Note You need to log in before you can comment on or make changes to this bug.