Bug 1464641 - gluster-block create prints "(null)" when tcmu-runner is not running
gluster-block create prints "(null)" when tcmu-runner is not running
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Prasanna Kumar Kalever
Sweta Anandpara
3.3.0-devel-freeze-exception
:
: 1465489 (view as bug list)
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-06-24 02:48 EDT by Pranith Kumar K
Modified: 2017-09-21 00:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: gluster-block-0.2.1-4.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:20:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2017-06-24 02:48:15 EDT
Description of problem:
11:18:28 :( ⚡ gluster-block create d1/1-img ha 1 localhost.localdomain 10GiB
(null)
RESULT:FAIL

Version-Release number of selected component (if applicable):


How reproducible:
Always, when tcmu-runner is not running on my machine

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
11:45:18 :( ⚡ gluster-block create d1/1-img ha 1 localhost.localdomain 10GiB
failed to configure on localhost.localdomain tcmu-runner not running
RESULT:FAIL


Additional info:
Comment 2 Pranith Kumar K 2017-06-24 02:49:11 EDT
https://review.gluster.org/17622
Comment 5 Prasanna Kumar Kalever 2017-06-28 02:49:26 EDT
*** Bug 1465489 has been marked as a duplicate of this bug. ***
Comment 10 Sweta Anandpara 2017-07-17 05:14:57 EDT
Have been testing in gluster-block-0.2.1-6 and glusterfs-3.8.4-33.
As mentioned in comment8, the code path to hit this issue is dead, and hence we will never end up in a situation as mentioned in description. 

Having said that, did execute the steps in and around the ones mentioned. Also checked for any unexpected errors in log messages- and it does not seem to be out of the ordinary.

Moving this bug to verified in 3.3.
Comment 12 errata-xmlrpc 2017-09-21 00:20:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2773

Note You need to log in before you can comment on or make changes to this bug.