Bug 1465489 - gluster block device creation fails with (null) error
gluster block device creation fails with (null) error
Status: CLOSED DUPLICATE of bug 1464641
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Prasanna Kumar Kalever
Rahul Hinduja
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 10:11 EDT by krishnaram Karthick
Modified: 2017-06-28 02:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 02:49:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnaram Karthick 2017-06-27 10:11:04 EDT
Description of problem:

gluster block create command fails to create a block device.

[root@dhcp46-136 ~]# gluster-block create block-vol-01/sample-block-01 ha 3 10.70.46.136,10.70.46.202,10.70.47.123 1GiB
(null)
RESULT:FAIL

gluster vol status
Status of volume: block-vol-01
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick 10.70.46.202:/bricks/brick1/bvol1     49154     0          Y       13063
Brick 10.70.46.136:/bricks/brick1/bvol1     49154     0          Y       13101
Brick 10.70.47.123:/bricks/brick1/bvol1     49154     0          Y       2801 
Self-heal Daemon on localhost               N/A       N/A        Y       2821 
Self-heal Daemon on 10.70.46.202            N/A       N/A        Y       13083
Self-heal Daemon on 10.70.46.136            N/A       N/A        Y       13121
 
Task Status of Volume block-vol-01
------------------------------------------------------------------------------
There are no active volume tasks


CLI log:

[2017-06-27 13:29:03.920630] ERROR: glfs_init() on block-vol-01 failed[Input/output error] [at glfs-operations.c+70 :<glusterBlockVolumeInit>]
[2017-06-27 13:32:25.615218] ERROR: glfs_open(sample-block-01) failed[No such file or directory] [at glfs-operations.c+368 :<blockGetMetaInfo>]
[2017-06-27 13:32:40.391987] ERROR: glfs_open(sample-block-01) failed[No such file or directory] [at glfs-operations.c+368 :<blockGetMetaInfo>]


Version-Release number of selected component (if applicable):
dhcp46-136 ~]# rpm -qa | grep 'gluster'
glusterfs-3.8.4-31.el7rhgs.x86_64
glusterfs-server-3.8.4-31.el7rhgs.x86_64
gluster-block-0.2.1-2.el7rhgs.x86_64
glusterfs-client-xlators-3.8.4-31.el7rhgs.x86_64
glusterfs-api-3.8.4-31.el7rhgs.x86_64
glusterfs-cli-3.8.4-31.el7rhgs.x86_64
glusterfs-libs-3.8.4-31.el7rhgs.x86_64
glusterfs-fuse-3.8.4-31.el7rhgs.x86_64


How reproducible:
1/1

However, gluster block vol created successfully later using the same command!

Steps to Reproduce:
1. configure gluster block and create a gluster block device

Actual results:
gluster-block creation fails

Expected results:
gluster-block should be created successfully and a proper error message needs to be displayed when there is a failure

Additional info:
sosreports shall be attached
Comment 3 Prasanna Kumar Kalever 2017-06-28 02:49:26 EDT

*** This bug has been marked as a duplicate of bug 1464641 ***

Note You need to log in before you can comment on or make changes to this bug.