Bug 1464654 - seabios hangs in PXE option ROM
seabios hangs in PXE option ROM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: seabios (Show other bugs)
7.3
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Ademar Reis
FuXiangChun
V2V
: ZStream
: 1398491 1418049 (view as bug list)
Depends On: 1392821
Blocks: TRACKER-bugs-affecting-libguestfs 1420851 1468480
  Show dependency treegraph
 
Reported: 2017-06-24 05:40 EDT by Jaroslav Spanko
Modified: 2017-08-01 13:44 EDT (History)
18 users (show)

See Also:
Fixed In Version: seabios-1.10.2-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1468480 (view as bug list)
Environment:
Last Closed: 2017-08-01 13:44:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qemu-kvm-rhev package (1.30 MB, text/plain)
2017-06-24 07:13 EDT, Jaroslav Spanko
no flags Details
qemu-kvm package (7.80 KB, text/plain)
2017-06-24 07:14 EDT, Jaroslav Spanko
no flags Details
guestfish qemu-kvm (6.49 KB, text/plain)
2017-06-24 07:43 EDT, Jaroslav Spanko
no flags Details
guestfish qemu-kvm-rhev (51.30 KB, text/plain)
2017-06-24 07:43 EDT, Jaroslav Spanko
no flags Details

  None (edit)
Description Jaroslav Spanko 2017-06-24 05:40:31 EDT
Description of problem:
The virt-v2v hangs on the PXE boot 
# virt-v2v -i ova /home/test/VM/ -of qcow2 -o local -os /home/test/ -v

also the LIBGUESTFS_BACKEND=direct guestfish -v -x --network -a /dev/null run test hangs on the same 
-------
libguestfs: responding to serial console Device Status Report
\x1b[1;256r\x1b[256;256H\x1b[6n
Google, Inc.
Serial Graphics Adapter 12/29/13
SGABIOS $Id: sgabios.S 8 2010-04-22 00:03:40Z nlaredo $ (mockbuild@) Sun Dec 29 03:43:06 UTC 2013
Term: 80x24
4 0
SeaBIOS (version 1.9.1-5.el7_3.3)
iPXE (http://ipxe.org) 00:05.0 C100 PCI2.10 PnP PMM
-------

Version-Release number of selected component (if applicable):
This is reproducible with qemu-kvm
qemu-kvm-1.5.3-126.el7_3.9.x86_64                           
qemu-kvm-common-1.5.3-126.el7_3.9.x86_64                    
ipxe-roms-qemu-20160127-5.git6366fa7a.el7.noarch

but not with qemu-kvm-rhev
qemu-kvm-rhev-2.6.0-28.el7_3.9.x86_64
qemu-kvm-common-rhev-2.6.0-28.el7_3.9.x86_64
ipxe-roms-qemu-20160127-5.git6366fa7a.el7.noarch

The ipxe package is the same

How reproducible:
100% with qemu-kvm package, looks like it cannot get runtime segment address and length as i would expect
iPXE (http://ipxe.org) 00:05.0 C100 PCI2.10 PnP PMM+31F97690+31EF7690 C100                                                                            

Steps to Reproduce:
1. run virt-v2v with qemu-kvm 
2. it hangs on iPXE boot


Actual results:
iPXE (http://ipxe.org) 00:05.0 C100 PCI2.10 PnP PMM and hang

Expected results:
iPXE (http://ipxe.org) 00:05.0 C100 PCI2.10 PnP PMM+31F97690+31EF7690 C100 and move forward                                                               

Thanks
Comment 2 Richard W.M. Jones 2017-06-24 06:37:34 EDT
Please add both -v and -x flags, and attach the complete output.
Comment 3 Richard W.M. Jones 2017-06-24 06:44:30 EDT
We had this reported before (twice), but unfortunately the first
bug was rather incoherent, and the second bug was closed before
anyone bothered to CC me on it.

  https://bugzilla.redhat.com/show_bug.cgi?id=1398491
  https://bugzilla.redhat.com/show_bug.cgi?id=1418049

So I would really like to get to the bottom of this, as I was not
able to reproduce the issue before.

Please as well as the output in comment 2, I also need to see
the output of these command run as root:

  rm -rf /var/tmp/.guestfs-0
  LIBGUESTFS_BACKEND=direct guestfish -v -x --network -a /dev/null run

Attach the output from comment 2 and comment 3 to this bug as attachments.
Comment 4 Jaroslav Spanko 2017-06-24 06:51:42 EDT
Hi Rich
I think i know where is the problem, please correct me if I am wrong.
I checked these 2 BZ and mine and have one same:

Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory

and CPU which do not support hardware virtualization.
Once i fix the modules/enable HW back PXE boots ok.
Comment 5 Richard W.M. Jones 2017-06-24 06:54:59 EDT
(In reply to Jaroslav Spanko from comment #4)
> Hi Rich
> I think i know where is the problem, please correct me if I am wrong.
> I checked these 2 BZ and mine and have one same:
> 
> Could not access KVM kernel module: No such file or directory
> failed to initialize KVM: No such file or directory
> 
> and CPU which do not support hardware virtualization.
> Once i fix the modules/enable HW back PXE boots ok.

However it is supposed to work even without KVM, and we
support that too.  If it doesn't work that's a problem.
Unfortunately I was not able to reproduce it before.

I'd appreciate the information requested above (with the
KVM module disabled again so the bug reproduces).
Comment 6 Jaroslav Spanko 2017-06-24 07:12:10 EDT
Sure, uploaded
additional info
qemu-kvm-rhev-2.6.0-28.el7_3.9.x86_64
does not have this problem also with disabled/non-exist kvm modules
looks like only 
qemu-kvm-1.5.3-126.el7_3.9.x86_64                           

Thanks a lot !
Comment 7 Jaroslav Spanko 2017-06-24 07:13 EDT
Created attachment 1291466 [details]
qemu-kvm-rhev package
Comment 8 Jaroslav Spanko 2017-06-24 07:14 EDT
Created attachment 1291467 [details]
qemu-kvm package
Comment 9 Jaroslav Spanko 2017-06-24 07:43 EDT
Created attachment 1291468 [details]
guestfish qemu-kvm
Comment 10 Jaroslav Spanko 2017-06-24 07:43 EDT
Created attachment 1291469 [details]
guestfish qemu-kvm-rhev
Comment 11 Richard W.M. Jones 2017-06-24 07:47:41 EDT
The one line reproducing command (which works even with KVM enabled) is:

  LIBGUESTFS_BACKEND_SETTINGS=force_tcg LIBGUESTFS_BACKEND=direct guestfish -v -x --network -a /dev/null run

After downgrading packages one by one, I found the problem is ... seabios.

  seabios-bin-1.9.1-5.el7_3.3.noarch -> fails
  seabios-bin-1.10.2-3.el7.noarch -> works

Luckily we are going to rebase seabios in RHEL 7.4 so this bug
will be fixed by that rebase.  In other words, there is nothing
to do here.
Comment 12 Richard W.M. Jones 2017-06-24 07:54:32 EDT
*** Bug 1398491 has been marked as a duplicate of this bug. ***
Comment 13 Richard W.M. Jones 2017-06-24 07:55:02 EDT
*** Bug 1418049 has been marked as a duplicate of this bug. ***
Comment 14 Chao Yang 2017-06-25 00:08:20 EDT
This issue can be reproduced on seabios-bin-1.9.1-5.el7_3.3.noarch.rpm by steps below.

- Steps:

1. remove kvm-intel and kvm module
2. start qemu-kvm instance, for example:

/usr/libexec/qemu-kvm -device sga -serial stdio -drive id=drive_image1,if=none,snapshot=off,aio=native,cache=none,format=qcow2,file=/home/rhel73-64-virtio.qcow2 -device virtio-blk-pci,id=image1,drive=drive_image1,bus=pci.0 -boot nc


- Packages in test:

qemu-kvm-1.5.3-126.el7_3.10.x86_64
3.10.0-514.25.2.el7.x86_64
seabios-bin-1.9.1-5.el7_3.3.noarch.rpm


- Actual Result:

It hung at iPXE booting. Detailed output:

Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
Back to tcg accelerator.
VNC server running on `::1:5900'

Google, Inc.
Serial Graphics Adapter 12/29/13
SGABIOS $Id: sgabios.S 8 2010-04-22 00:03:40Z nlaredo $ (mockbuild@) Sun Dec 29 03:43:06 UTC 2013
4 0

 eaBIOS (version 1.9.1-5.el7_3.3)


iPXE (http://ipxe.org) 00:03.0 CA80 PCI2.10 PnP PMM




- Verified pass with same steps above.

- Packages in test:

seabios-bin-1.10.2-3.el7.noarch
qemu-kvm-1.5.3-141.el7.x86_64
3.10.0-686.el7.x86_64


- Actual Result:

Guest could be booted correctly. Detailed output is as below:

Google, Inc.
Serial Graphics Adapter 12/29/13
SGABIOS $Id: sgabios.S 8 2010-04-22 00:03:40Z nlaredo $ (mockbuild@) Sun Dec 29 03:43:06 UTC 2013
4 0

 eaBIOS (version 1.10.2-3.el7)


iPXE (http://ipxe.org) 00:03.0 CA80 PCI2.10 PnP PMM+07F964B0+07EF64B0 CA80
                                                                               


Booting from ROM...
iPXE (PCI 00:03.0) starting execution...ok
iPXE initialising devices...ok



      Red Hat Enterprise Linux Server (3.10.0-648.el7.x86_64) 7.4 (Maipo)       
      Red Hat Enterprise Linux Server (3.10.0-632.el7.x86_64) 7.4 (Maipo)      
      Red Hat Enterprise Linux Server (0-rescue-b7f6db9070b5467abfb5d407e4a1b4>
                                                                               
                                                                                                                                                                                                                                                                                                                              Use the ^ and v keys to change the selection.                                                                                      robing EDD (edd=off to disable)... oktem, or 'c' for a command prompt.
Comment 16 Pawan kumar Vilayatkar 2017-06-29 05:22:49 EDT
Hello ,

Please let us know if package seabios-bin-1.10.2-3.el7.noarch could be backported to 7.x and if no,  then what is fix for 7.3.x ?
Comment 24 juzhang 2017-07-06 03:38:01 EDT
According to comment14 and comment22, set this bz as verified.
Comment 25 Karen Noel 2017-07-06 06:57:32 EDT
How to we get GSS or PM approval?
Comment 26 Dr. David Alan Gilbert 2017-07-06 07:25:09 EDT
Note bz 1425516 would also benefit from this fix
Comment 27 Martin Tessun 2017-07-06 10:55:21 EDT
(In reply to Karen Noel from comment #25)
> How to we get GSS or PM approval?

Typically with a business justification.
From the nature of this, I believe fixing this in 7.3.z makes sense.
Approving.
Comment 29 errata-xmlrpc 2017-08-01 13:44:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1855

Note You need to log in before you can comment on or make changes to this bug.