Bug 1468480 - seabios hangs in PXE option ROM
seabios hangs in PXE option ROM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: seabios (Show other bugs)
7.3
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Gerd Hoffmann
FuXiangChun
: ZStream
Depends On: 1464654
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 04:19 EDT by Oneata Mircea Teodor
Modified: 2017-08-08 12:21 EDT (History)
18 users (show)

See Also:
Fixed In Version: seabios-1.9.1-5.el7_3.4
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1464654
Environment:
Last Closed: 2017-08-08 12:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oneata Mircea Teodor 2017-07-07 04:19:53 EDT
This bug has been copied from bug #1464654 and has been proposed to be backported to 7.3 z-stream (EUS).
Comment 2 Ademar Reis 2017-07-07 09:59:54 EDT
Reading bug #1464654, I couldn't find the exact commit to backport, but the rebase done in RHEL-7.4 fixed the problem.
Comment 5 Richard W.M. Jones 2017-07-11 04:11:38 EDT
I tested the build (comment 4) using this reproducer:
https://bugzilla.redhat.com/show_bug.cgi?id=1464654#c11

kernel-3.10.0-681.el7.x86_64
qemu-kvm-1.5.3-126.el7_3.10.x86_64
seabios-bin-1.9.1-5.el7_3.3.noarch

=> bug reproduces

kernel-3.10.0-681.el7.x86_64
qemu-kvm-1.5.3-126.el7_3.10.x86_64
seabios-bin-1.9.1-5.el7_3.3.bz1468480.1.noarch

=> bug is fixed
Comment 6 Gerd Hoffmann 2017-07-11 05:02:01 EDT
patch posted.
Comment 7 Miroslav Rezanina 2017-07-14 04:39:30 EDT
Fix included in seabios-1.9.1-5.el7_3.4
Comment 9 FuXiangChun 2017-07-25 22:04:37 EDT
According to reproducer in comment https://bugzilla.redhat.com/show_bug.cgi?id=1464654#c14.

Reproduced bug with:
seabios-bin-1.9.1-5.el7_3.2.noarch
qemu-kvm-1.5.3-126.el7_3.10.x86_64
3.10.0-693.el7.x86_64
ipxe-roms-qemu-20170123-1.git4e85b27.el7.noarch

verified bug with:
seabios-bin-1.9.1-5.el7_3.4.noarch
qemu-kvm-1.5.3-126.el7_3.10.x86_64
3.10.0-693.el7.x86_64
ipxe-roms-qemu-20170123-1.git4e85b27.el7.noarch

so,set this bug as verified.
Comment 11 errata-xmlrpc 2017-08-08 12:21:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2439

Note You need to log in before you can comment on or make changes to this bug.