Bug 146486 - gimp icon won't theme
gimp icon won't theme
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks: 119991
  Show dependency treegraph
 
Reported: 2005-01-28 14:37 EST by Jeff Moe (jebba)
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 03:04:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Moe (jebba) 2005-01-28 14:37:57 EST
Icons in the menu do not change when the theme is changed. This
is true even if the theme has an icon of the correct name.

The cause of this is that in
/usr/share/applications/gimp-2.2.desktop
the Icon= line has the absolute path to the icon instead of just the
icon name.

Icon=/usr/share/gimp/2.0/images/wilber-icon.png
When it should have:
Icon=wilber-icon.png

The icon should be put in the hicolor theme, per freedesktop.org.
/usr/share/icons/hicolor/48x48/apps/

See also: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119991
Comment 1 Jeff Moe (jebba) 2005-01-28 14:44:19 EST
Set to block #119991
Comment 2 Nils Philippsen 2005-02-01 03:04:10 EST
Fixed in gimp-2.2.3-0.fc3.2.

Note You need to log in before you can comment on or make changes to this bug.